Difference between revisions of "All keyboard shortcut keys"

From Second Life Wiki
Jump to: navigation, search
m (Navigation)
(Added Vieewer 3.2 keyboard shortcuts)
Line 3: Line 3:
  
 
For a list of only the most commonly-used keyboard shortcut keys, see [[Keyboard shortcut keys]]. For consideration of new shortcuts, look at [[Shortcuts SL-UX]] to minimize trouble in different operating systems.
 
For a list of only the most commonly-used keyboard shortcut keys, see [[Keyboard shortcut keys]]. For consideration of new shortcuts, look at [[Shortcuts SL-UX]] to minimize trouble in different operating systems.
 +
 +
== Viewer 3.2 Keyboard Shortcuts ==
 +
 +
[[File:Viewer3KeyboardShortcuts.png]]
  
 
== Menus ==
 
== Menus ==

Revision as of 19:28, 13 November 2011

This page contains a comprehensive list of keyboard shortcut keys in the Second Life Viewer, even ones that are rarely used.

For a list of only the most commonly-used keyboard shortcut keys, see Keyboard shortcut keys. For consideration of new shortcuts, look at Shortcuts SL-UX to minimize trouble in different operating systems.

Viewer 3.2 Keyboard Shortcuts

Viewer3KeyboardShortcuts.png

Menus

click the boxed arrows to sort on columns
Key Viewer 2.8 Viewer 1.23
Ctrl+P Me > Preferences Edit > Preferences...
Ctrl+I Me > My Inventory (sidebar) View > Inventory
Ctrl+Shift ⇧+I > New inventory Window (inventory floaters) ~(not used)
Ctrl+G Me > My Gestures Edit > Gestures...
Alt+Shift ⇧+S Me > Movement > Sit Down ~(not used)
Home Me > Movement > Fly World > Fly
Ctrl+R Me > Movement > Always Run World > Always Run
Ctrl+Q Me > Quit File > Quit
Ctrl+Shift ⇧+F Communicate > My Friends Edit > Friends...
Ctrl+Shift ⇧+G Communicate > My Groups ~(not used)
Ctrl+H Communicate > Nearby Chat View > Local Chat
Ctrl+Shift ⇧+A Communicate > Nearby People ~
Ctrl+Shift ⇧+M World > Mini-Map View > Mini-Map
Ctrl+M World > World Map View > World Map
Ctrl+F World > Search
Advanced > Shortcuts > Search
Edit > Search...
Ctrl+Shift ⇧+S World > Snapshot File > Take or Refresh Snapshot
Ctrl+Alt+Shift ⇧+N World > Show > Beacons View > Beacons
Ctrl+Alt+Shift ⇧+P World > Show > Property Lines View > Property Lines
Ctrl+Alt+D
Ctrl+Alt+Shift ⇧+D
World > Show > Advanced Menu
Advanced > Shortcuts > Show Advanced Menu - legacy shortcut
(keyboard only)
Ctrl+Shift ⇧+H World > Teleport Home World > Teleport Home
Ctrl+Shift ⇧+Y World > Sun > Midday World > Environment Settings > Midday
Ctrl+Shift ⇧+N World > Sun > Sunset World > Environment Settings > Sunset
Ctrl+B Build > Build see B
Ctrl+1 Build > Select Build Tool > Focus Tool
Advanced > Shortcuts > Focus Tool
Tools > Select Tool > Focus
Ctrl+2 Build > Select Build Tool > Move Tool
Advanced > Shortcuts > Move Tool
Tools > Select Tool > Move
Ctrl+3 Build > Select Build Tool > Edit Tool
Advanced > Shortcuts > Edit Tool
Tools > Select Tool > Edit
Ctrl+4 Build > Select Build Tool > Create Tool
Advanced > Shortcuts > Create Tool
Tools > Select Tool > Create
Ctrl+5 Build > Select Build Tool > Land Tool
Advanced > Shortcuts > Land Tool
Tools > Select Tool > Land
Ctrl+L Build > Link Tools > Link
Ctrl+Shift ⇧+L Build > Unlink Tools > Unlink
Ctrl+. Build > Select Linked Parts > Select Next Part ~
Ctrl+, Build > Select Linked Parts > Select Previous Part ~
Ctrl+Shift ⇧+. Build > Select Linked Parts > Include Next Part ~
Ctrl+Shift ⇧+, Build > Select Linked Parts > Include Previous Part ~
H Build > Focus on Selection Tools > Focus on Selection
Shift ⇧+H Build > Zoom to Selection Tools > Zoom to Selection
G Build > Options > Snap to Grid Tools > Snap to Grid
Shift ⇧+X Build > Options > Snap Object XY to Grid Tools > Snap Object XY to Grid
Shift ⇧+G Build > Options > Use Selection for Grid Tools > Use Selection for Grid
Ctrl+Shift ⇧+B Build > Options > Grid Options Tools > Grid Options...
Ctrl+U Build > Upload > Image
> Upload > Image (inventory floaters)
Advanced > Shortcuts > Image
File > Upload Image...
Ctrl+Z Build > Undo Edit > Undo
Ctrl+Y Build > Redo Edit > Redo
F1 Help > Second Life Help Help > Second Life Help
Ctrl+Alt+R Advanced > Rebake Textures Advanced > Character > Rebake Textures
Ctrl+Shift ⇧+1 Advanced > Performance Tools > Statistics Bar View > Statistics Bar
Ctrl+Alt+T Advanced > Highlighting and Visibility > Highlight Transparent View > Highlight Transparent
Alt+Shift ⇧+H Advanced > Highlighting and Visibility > Show HUD Attachments View > Show HUD Attachments
Ctrl+Alt+Shift ⇧+1 Advanced > Rendering Types > Simple Advanced > Rendering > Types > Simple
Ctrl+Alt+Shift ⇧+2 Advanced > Rendering Types > Alpha Advanced > Rendering > Types > Alpha
Ctrl+Alt+Shift ⇧+3 Advanced > Rendering Types > Tree Advanced > Rendering > Types > Tree
Ctrl+Alt+Shift ⇧+4 Advanced > Rendering Types > Character Advanced > Rendering > Types > Character
Ctrl+Alt+Shift ⇧+5 Advanced > Rendering Types > SurfacePatch Advanced > Rendering > Types > SurfacePatch
Ctrl+Alt+Shift ⇧+6 Advanced > Rendering Types > Sky Advanced > Rendering > Types > Sky
Ctrl+Alt+Shift ⇧+7 Advanced > Rendering Types > Water Advanced > Rendering > Types > Water
Ctrl+Alt+Shift ⇧+8 Advanced > Rendering Types > Ground Advanced > Rendering > Types > Ground
Ctrl+Alt+Shift ⇧+9 Advanced > Rendering Types > Volume Advanced > Rendering > Types > Volume
Ctrl+Alt+Shift ⇧+0 Advanced > Rendering Types > Grass Advanced > Rendering > Types > Grass
Ctrl+Alt+Shift ⇧+- Advanced > Rendering Types > Clouds Advanced > Rendering > Types > Clouds
Ctrl+Alt+Shift ⇧+= Advanced > Rendering Types > Particles
Advanced > Highlighting and Visibility > Hide Particles
Advanced > Rendering > Types > Particles
Ctrl+Alt+Shift ⇧+\ Advanced > Rendering Types > Bump Advanced > Rendering > Types > Bump
Ctrl+Alt+F1 Advanced > Rendering Features > UI Advanced > Rendering > Features > UI
Ctrl+Alt+F2 Advanced > Rendering Features > Selected Advanced > Rendering > Features > Selected
Ctrl+Alt+F3 Advanced > Rendering Features > Highlighted Advanced > Rendering > Features > Highlighted
Ctrl+Alt+F4 Advanced > Rendering Features > Dynamic Textures Advanced > Rendering > Features > Dynamic Textures
Ctrl+Alt+F5 Advanced > Rendering Features > Foot Shadows Advanced > Rendering > Features > Foot Shadows
Ctrl+Alt+F6 Advanced > Rendering Features > Fog Advanced > Rendering > Features > Fog
Ctrl+Alt+F8 Advanced > Rendering Features > Test FRInfo Advanced > Rendering > Features > Test FRInfo
Ctrl+Alt+F9 Advanced > Rendering Features > Flexible Objects Advanced > Rendering > Features > Flexible Objects
Ctrl+W Advanced > Shortcuts > Close Window File > Close Window
Ctrl+Shift ⇧+W Advanced > Shortcuts > Close All Windows File > Close All Windows
Ctrl+` Advanced > Shortcuts > Snapshot to Disk File > Snapshot to Disk
M Advanced > Shortcuts > Mouselook View > Mouselook
Alt+Shift ⇧+F Advanced > Shortcuts > Joystick Flycam View > Joystick Flycam
Esc Advanced > Shortcuts > Reset View View > Reset View
Ctrl+\ Advanced > Shortcuts > Look at Last Chatter View > Look at Last Chatter
Ctrl+0 Advanced > Shortcuts > Zoom In View > Zoom In
Ctrl+9 Advanced > Shortcuts > Zoom Default View > Zoom Default
Ctrl+8 Advanced > Shortcuts > Zoom Out View > Zoom Out
Ctrl+Alt+Q Advanced > Show Develop Menu ~(not used)
Ctrl+Shift ⇧+3 Develop > Consoles > Texture Console Advanced > Consoles > Texture Console
Ctrl+Shift ⇧+4 Develop > Consoles > Debug Console Advanced > Consoles > Debug Console
Ctrl+Shift ⇧+5 Develop > Consoles > Notifications Console ~
Ctrl+Shift ⇧+6 Develop > Consoles > Texture Size Console ~
Ctrl+Shift ⇧+7 Develop > Consoles > Texture Category Console ~
Ctrl+Shift ⇧+9 Develop > Consoles > Fast Timers Advanced > Consoles > Fast Timers
Ctrl+Alt+Shift ⇧+H Develop > Consoles > Badge (keyboard only)
Ctrl+Alt+Shift ⇧+U Develop > Show Info > Show Updates to Objects Advanced > Show Updates
Ctrl+Alt+Shift ⇧+B Force Breakpoint ~
Ctrl+Alt+Shift ⇧+T Develop > Rendering > Selected Texture Info Advanced > Rendering > Selected Texture Info
Ctrl+Shift ⇧+R Develop > Rendering > Wireframe Advanced > Rendering > Wireframe
Ctrl+Shift ⇧+O Develop > Rendering > Object-Object Occlusion Advanced > Rendering > Object-Object Occlusion
Ctrl+Alt+L Develop > Network > Drop a Packet Advanced > Network > Drop a Packet
Ctrl+Shift ⇧+Z Develop > UI > Web Content Browser ~
Ctrl+Shift ⇧+P Develop > UI > Print Selected Object Info Advanced > UI > Print Selected Object Info
Shift ⇧+P Develop > UI > Print Agent Info Advanced > UI > Print Agent Info
Ctrl+Alt+Shift ⇧+M Develop > UI > Memory Stats Advanced > UI > Memory Stats
Ctrl+Shift ⇧+` Develop > UI > Region Debug Console ~(not used)
Ctrl+Alt+Shift ⇧+A Develop > Avatar > Debug Avatar Textures ~
Alt+Shift ⇧+M Develop > Avatar > Dump Local Textures ~
Ctrl+Alt+G Develop > Request Admin Status Advanced > Request Admin Status
Ctrl+Alt+Shift ⇧+G Develop > Leave Admin Status Advanced > Leave Admin Status
Ctrl+Alt+Shift ⇧+O Admin > Object > Take Copy Admin > Object > Take Copy
Ctrl+Alt+Shift ⇧+Del Admin > Object > Delete Admin > Object > Delete
Ctrl+Alt+Shift ⇧+L Admin > Object > Lock Admin > Object > Lock
Ctrl+Alt+Shift ⇧+I Admin > Object > Get Asset IDs Admin > Object > Get Asset IDs
Ctrl+Alt+Shift ⇧+C Admin > Parcel > Set to Linden Content Admin > Parcel > Set to Linden Content
Ctrl+X ~(keyboard only) Edit > Cut
Ctrl+C ~(keyboard only) Edit > Copy
Ctrl+V ~(keyboard only) Edit > Paste
Del ~(keyboard only) Edit > Delete
Ctrl+A ~(keyboard only) Edit > Select All
Ctrl+E ~(keyboard only) Edit > Deselect
Ctrl+D ~(keyboard only) Edit > Duplicate
B see Ctrl+B View > Build
Ctrl+T ~(not used) View > Communicate
Ctrl+Shift ⇧+T ~(not used, use ShowHoverTips debug setting) View > Hover Tips > Show Tips
Alt+Enter ↵ ~(not used) View > Toggle Fullscreen
Enter ↵ ~(focus to chat bar) World > Chat
Ctrl+Shift ⇧+2 ~(not used) Advanced > Consoles > Frame Console
Ctrl+Shift ⇧+0 ~(not used) Advanced > Consoles > Memory
Ctrl+Shift ⇧+F2 ~(not used?) Advanced > Reload personal settings overrides
Ctrl+Alt+F7 ~(not used) Advanced > Rendering > Features > Palletized Textures
Ctrl+Alt+F Develop > UI > Dump Focus Holder (no shortcut) Advanced > UI > Dump Focus Holder
Ctrl+Alt+V Develop > Show Admin Menu (no shortcut) Advanced > View Admin Options

Navigation

Key Viewer 2.8 Viewer 1.23
W or Move forward
S or Move backward
A or Turn left (normal view)
Move left (mouselook)
D or Turn right (normal view)
Move right(mouselook)
Shift ⇧+A or Shift ⇧+ Move left
Shift ⇧+D or Shift ⇧+ Move right
E or PgUp Jump / Fly up
C or PgDown Crouch / Fly down
F or Home Fly on/off

Camera

Key Viewer 2.8 Viewer 1.23
Alt+W or Alt+ Zoom in
Alt+S or Alt+ Zoom out
Alt+A or Alt+ or Ctrl+Alt+ Orbit clockwise
Alt+D or Alt+ or Ctrl+Alt+ Orbit anticlockwise
Alt+E or Alt+PgUp or Ctrl+Alt+ Orbit forward
Alt+C or Alt+PgDown or Ctrl+Alt+ Orbit back
Ctrl+Alt+Shift ⇧+W or Ctrl+Alt+Shift ⇧+ Pan up
Ctrl+Alt+Shift ⇧+S or Ctrl+Alt+Shift ⇧+ Pan down
Ctrl+Alt+Shift ⇧+A or Ctrl+Alt+Shift ⇧+ Pan left
Ctrl+Alt+Shift ⇧+D or Ctrl+Alt+Shift ⇧+ Pan right

Chat Bar

Key Viewer 2.8 Viewer 1.23
Ctrl+Enter ↵ Shout
Ctrl+ Recall previous chat/IM input line.
Ctrl+ Recall next chat/IM input line.

Other

Key Viewer 2.8 Viewer 1.23
Ctrl+S Save notecard/script.

Login window

Key Viewer 2.8 Viewer 1.23
Ctrl+Shift ⇧+G Grid selection pulldown
Ctrl+T Test floater
F2 ~(not used?) TOS window