All keyboard shortcut keys

From Second Life Wiki
Revision as of 14:56, 24 February 2010 by Erica Linden (Talk | contribs)

Jump to: navigation, search

This page contains a comprehensive list of keyboard shortcut keys in the Second Life Viewer, even ones that are rarely used.

For a list of only the most commonly-used keyboard shortcut keys, see Keyboard shortcut keys. For consideration of new shortcuts, look at Shortcuts SL-UX to minimize trouble in different operating systems.

Menus

File

 Ctrl-U        -->  File > Upload Image...
 Ctrl-W        -->  File > Close Window
 Ctrl-Shift-W  -->  File > Close All Windows
 Ctrl-Shift-S  -->  File > Take or Refresh Snapshot
 Ctrl-`        -->  File > Snapshot to Disk
 Ctrl-Q        -->  File > Quit

Edit

 Ctrl-Z        -->  Edit > Undo
 Ctrl-Y        -->  Edit > Redo
 Ctrl-X        -->  Edit > Cut
 Ctrl-C        -->  Edit > Copy
 Ctrl-V        -->  Edit > Paste
 Del           -->  Edit > Delete
 Ctrl-F        -->  Edit > Search...
 Ctrl-A        -->  Edit > Select All
 Ctrl-E        -->  Edit > Deselect
 Ctrl-D        -->  Edit > Duplicate
 Ctrl-G        -->  Edit > Gestures...
 Ctrl-Shift-F  -->  Edit > Friends...
 Ctrl-P        -->  Edit > Preferences...

View

 M                 -->  View > Mouselook
 B                 -->  View > Build
 Alt-Shift-F       -->  View > Joystick Flycam
 Esc               -->  View > Reset View
 Ctrl-\            -->  View > Look at Last Chatter
 Ctrl-H            -->  View > Local Chat
 Ctrl-T            -->  View > Communicate
 Ctrl-I            -->  View > Inventory
 Ctrl-M            -->  View > World Map
 Ctrl-Shift-M      -->  View > Mini-Map
 Ctrl-Shift-1      -->  View > Statistics Bar
 Ctrl-Alt-Shift-P  -->  View > Property Lines
 Ctrl-Shift-T      -->  View > Hover Tips > Show Tips
 Ctrl-Alt-T        -->  View > Highlight Transparent
 Ctrl-Alt-Shift-N  -->  View > Beacons
 Alt-Shift-H       -->  View > Show HUD Attachments
 Ctrl-0            -->  View > Zoom In
 Ctrl-9            -->  View > Zoom Default
 Ctrl-8            -->  View > Zoom Out
 Alt-Enter         -->  View > Toggle Fullscreen  (tied to crashes - removed in 2.0)

World

 Enter         -->  World > Chat
 Ctrl-R        -->  World > Always Run
 Home          -->  World > Fly
 Ctrl-Shift-H  -->  World > Teleport Home
 
 Ctrl-Shift-Y  -->  World > Environment Settings > Midday
 Ctrl-Shift-N  -->  World > Environment Settings > Sunset

Tools

 Ctrl-1        -->  Tools > Select Tool > Focus
 Ctrl-2        -->  Tools > Select Tool > Move
 Ctrl-3        -->  Tools > Select Tool > Edit
 Ctrl-4        -->  Tools > Select Tool > Create
 Ctrl-5        -->  Tools > Select Tool > Land
 
 G             -->  Tools > Snap to Grid
 Shift-X       -->  Tools > Snap Object XY to Grid
 Shift-G       -->  Tools > Use Selection for Grid
 Ctrl-Shift-B  -->  Tools > Grid Options...
 Ctrl-L        -->  Tools > Link
 Ctrl-Shift-L  -->  Tools > Unlink
 H             -->  Tools > Focus on Selection
 Shift-H       -->  Tools > Zoom to Selection

Help

 F1  -->  Help > Second Life Help

Advanced

 Ctrl-Shift-2      -->  Advanced > Consoles > Frame Console
 Ctrl-Shift-3      -->  Advanced > Consoles > Texture Console
 Ctrl-Shift-4      -->  Advanced > Consoles > Debug Console
 Ctrl-Shift-9      -->  Advanced > Consoles > Fast Timers
 Ctrl-Shift-0      -->  Advanced > Consoles > Memory
 
 Ctrl-Shift-F2     -->  Advanced > Reload personal settings overrides
 
 Ctrl-Alt-Shift-1  -->  Advanced > Rendering > Types > Simple
 Ctrl-Alt-Shift-2  -->  Advanced > Rendering > Types > Alpha
 Ctrl-Alt-Shift-3  -->  Advanced > Rendering > Types > Tree
 Ctrl-Alt-Shift-4  -->  Advanced > Rendering > Types > Character
 Ctrl-Alt-Shift-5  -->  Advanced > Rendering > Types > SurfacePatch
 Ctrl-Alt-Shift-6  -->  Advanced > Rendering > Types > Sky
 Ctrl-Alt-Shift-7  -->  Advanced > Rendering > Types > Water
 Ctrl-Alt-Shift-8  -->  Advanced > Rendering > Types > Ground
 Ctrl-Alt-Shift-9  -->  Advanced > Rendering > Types > Volume
 Ctrl-Alt-Shift-0  -->  Advanced > Rendering > Types > Grass
 Ctrl-Alt-Shift--  -->  Advanced > Rendering > Types > Clouds
 Ctrl-Alt-Shift-=  -->  Advanced > Rendering > Types > Particles
 Ctrl-Alt-Shift-\  -->  Advanced > Rendering > Types > Bump
 
 Ctrl-Alt-F1       -->  Advanced > Rendering > Features > UI
 Ctrl-Alt-F2       -->  Advanced > Rendering > Features > Selected
 Ctrl-Alt-F3       -->  Advanced > Rendering > Features > Highlighted
 Ctrl-Alt-F4       -->  Advanced > Rendering > Features > Dynamic Textures
 Ctrl-Alt-F5       -->  Advanced > Rendering > Features > Foot Shadows
 Ctrl-Alt-F6       -->  Advanced > Rendering > Features > Fog
 Ctrl-Alt-F7       -->  Advanced > Rendering > Features > Palletized Textures
 Ctrl-Alt-F8       -->  Advanced > Rendering > Features > Test FRInfo
 Ctrl-Alt-F9       -->  Advanced > Rendering > Features > Flexible Objects
 
 Ctrl-Alt-Shift-T  -->  Advanced > Rendering > Selected Texture Info
 Ctrl-Shift-R      -->  Advanced > Rendering > Wireframe
 Ctrl-Shift-O      -->  Advanced > Rendering > Object-Object Occlusion
 
 Ctrl-Alt-F        -->  Advanced > UI > Dump Focus Holder
 Ctrl-Shift-P      -->  Advanced > UI > Print Selected Object Info
 Shift-P           -->  Advanced > UI > Print Agent Info
 Ctrl-Alt-Shift-M  -->  Advanced > UI > Memory Stats
 
 Ctrl-Alt-R        -->  Advanced > Character > Rebake Textures
 
 Ctrl-Alt-L        -->  Advanced > Network > Drop a Packet
 
 Ctrl-Alt-Shift-U  -->  Advanced > Show Updates (* Shortcut removed in SL 1.21)
 Ctrl-Alt-V        -->  Advanced > View Admin Options
 Ctrl-Alt-G        -->  Advanced > Request Admin Status
 Ctrl-Alt-Shift-G  -->  Advanced > Leave Admin Status

Admin

 Ctrl-Alt-Shift-O    -->  Admin > Object > Take Copy
 Ctrl-Alt-Shift-Del  -->  Admin > Object > Delete
 Ctrl-Alt-Shift-L    -->  Admin > Object > Lock
 Ctrl-Alt-Shift-I    -->  Admin > Object > Get Asset IDs
 
 Ctrl-Alt-Shift-C    -->  Admin > Parcel > Set to Linden Content

Other

 A and Left --> Turn left
 Shift-A and Shift-Left --> Move left
 C and PgDown --> Crouch / Fly down
 D and Right --> Turn right
 Shift-D and Shift-Right --> Move right
 E and PgUp --> Jump / Fly up
 F and Home --> Fly on/off
 S and Down --> Walk backward
 W and Up --> Walk forward
 Ctrl-Alt-D --> Toggle "Advanced" Menu on/off
 Ctrl-Alt-Shift-H  -->  Hippos!
 Ctrl-Enter --> Shout
 Ctrl-Up --> Recall previous chat/IM input line.
 Ctrl-Down --> Recall next chat/IM input line.
 Ctrl-S --> Save notecard/script.

Login Screen

Ctrl-Shift-G --> Grid selection pulldown
Ctrl-T --> Test floater
F2 --> TOS window