Does Second Life work with older versions of Windows, such as Windows 98, 98SE, Millenium Edition, or ME Computer?

From Second Life Wiki
Revision as of 17:00, 31 December 1969 by Fritz Linden (Talk | contribs)

Jump to: navigation, search
Kb-seal.png

This article is part of the Extended Second Life Knowledge Base that includes advanced and specialized information. This information was originally provided by Linden Lab, but is not actively maintained nor guaranteed to be accurate. Linden Lab does not certify nor assume any responsibility for this information.

See the official Second Life Knowledge Base for the most current information.

The Second Life viewer requires Windows 2000 or Windows XP; it does not work on older versions of Windows. You'll need to use Windows 2000, XP, or Vista to use the Second Life viewer.

Please check out the Second Life viewer's system requirements for current information regarding supported hardware and operating systems.