LSL Protocol/Restrained Life Relay/gender

From Second Life Wiki
Jump to: navigation, search

!gender

Not yet implemented

Description
meta command to pass a the gender of the relay wearer to the device using the relay.
Effect
When receiving this meta-command, the relay must send a special acknowledgment that contains the gender of the wearer (to be set via a menu, or a chat command, or a notecard). The valid genders are: "neuter", "male", "female", "hermaphrodite".
Motivation
There is currently no easy way to know the gender of the avatars interacting with a device, short of asking their player via a menu. It would be easier if the players could give the gender of their avatar to their relay once and for all (either via a notecard setting, a chat command or a menu button: it's up to the relay maker to decide how the gender is to be set), then have the devices automatically adapt their actions and/or emotes to it.

Henri Beauchamp 00:21, 7 April 2009 (UTC)

Discussion 
Please explain how !gender differs from the optional !vision extension. On !vision you wrote that you "agree 100%" that a relay should only be "providing gated access to viewer RLV commands". --Maike Short 16:04, 8 April 2009 (UTC)
 !gender is an ***information*** passed from the relay to the device using it so that the latter can adapt its behaviour to the avatar interacting with it (just like !version, excepted that !gender is an information about the avatar while !version is about the relay itself). On the other hand !vision is an ***action*** that should not be performed by the relay at all in the first place, but by a RLV blind fold. !gender makes no assumption whatsoever about the form or attachment point of the relay, unlike !vision. Henri Beauchamp 22:05, 12 April 2009 (UTC)
I fail to see the why the it makes a difference whether it is a query or an action command in how it is related to the RLV . It is an additional command which require additional code unless it is optional. Of course it is possible to not implement !gender in the relay but create its own gender-query object like you proposed for !vision. This has the huge advantage that it can be used outside the BDSM community, too. Don't get me wrong: I am not against optional extensions like !gender. I think they are important to get specified so that different relays and world objects can work together. Otherwise we risk incompatible proprietary and perhaps even a fork. But I consider it very strange that you write on the vision page that you don't want anything that is not RLV related and then propose something which is exactly that (not RLV related) yourself. --Maike Short 00:11, 13 April 2009 (UTC)
absolutely SUPPORT having the device CHANGE THE SEX in the relay. Ever heard of 'transformation machines'??? Having a RLV enabled transformation machine that not only changes the sex of the victim, but could force wear the contents of a folder (shape, skin and 'attachments') and have them restricted on detaching/attaching anything would be a RP godsend... FEMALE > MALE, MALE > FEMALE, etc... and while we're at it, extend this to the 'species' I hear about... MALE HUMAN > FEMALE FURRY, etc... opens up a whole new dimension of RP here... I vote AYE! --Ilana Debevec 01:04, 14 April 2009 (UTC)
Can this be done with @getdebug_avatarsex and @setdebug_avatarsex? --Maike Short 16:04, 8 April 2009 (UTC)
No, because @getdebug_avatarsex actually does not work properly at all (and @setdebug_avatarsex is not remembered over sessions either) and is actually only related with the shape used by your avatar (and mind you, my avatar is male, but I used a female shape for it. And I also saw "boyish" female Avs using male shapes)... Plus, "old" RestrainedLife viewers do not implement @getdebug. Henri Beauchamp 22:05, 12 April 2009 (UTC)
If the protocol is extended to read the gender, there should be a way to set it, too. The relay can of course refuse that, but it should be specified in the protocol right from the beginning, so that we don't need a later hacky extension. --Maike Short 05:24, 8 April 2009 (UTC)
No, the idea is simply for the device using the relay to get the information needed to adapt its emotes and/or sounds, and/or accessories (think of dildos and their different use for females and males...) to the gender of the avatar interacting with it, not to force some sex change (which sould be an ***action*** and should not be performed by the relay itself). Henri Beauchamp 22:05, 12 April 2009 (UTC)
I'd like to have a specification which is likely to stay consistent and compatible with future enhancements. We cannot see into the future obviously but some future requirements are predictable with a higher probability. If there is an extension to read the gender it is very likely that people want to set it, too. Especially keeping in mind that @setdebug_avatarsex does exist. We do not need to think about the details and all its problems until there is actually demand for it. But "!getgender" may be a better name than just "!gender". If we stick with !gender it may be a good idea to add: "If '!gender' is followed by a '/' the relay must reject it with 'ko' for now." --Maike Short 21:27, 13 April 2009 (UTC)


"ko" should be mentioned as valid response. --Maike Short 16:04, 8 April 2009 (UTC)
"ko" is the normal reply for any meta command that is not recognized by the relay. I know that most relays are not coded properly and never send "ko" for unrecognized and/or invalid commands... Mine does. Henri Beauchamp 22:05, 12 April 2009 (UTC)
It is still a good idea to list it as valid reply. There are relays out there which respond to !version with ko in some cases and world objects which whisper in public chat that your relay is too old because (integer) "ko" == 0. I expect similar problems with !gender if it is not spelled out that ko is allowed. And yes, I consider to let my relay default to ko, unless the user picked a gender. --Maike Short 00:11, 13 April 2009 (UTC)


Would it make sense to have an additional reply for the grammatical gender beside that biological one? For example: "hermaphrodite/she". --Maike Short 01:12, 13 April 2009 (UTC)


@gender is "just" a debug setting like any other... It is an integer variable that can hold any value, not just 0 or 1. I guess "hermaphrodite" and "shemale" can fit. Hehe. That's why I don't see why a !gender metacommand is necessary. It has nothing to do with this spec I think.

Marine Kelley 18:16, 14 April 2009 (UTC)