Difference between revisions of "LlSetInventoryName"
|Line 1:||Line 1:|
Latest revision as of 11:40, 19 June 2012
|LSL Portal||Functions | Events | Types | Operators | Constants | Flow Control | Script Library | Categorized Library | Tutorials|
|LSL Feature Request|
|The described function does not exist. This article is a feature request.|
//function void llSetInventoryName( string old, string new );
A few things that came to mind:
- What happens with a name collision?
- When used in a vendor it would be more useful to change the name of the item when giving, this would avoid the name collision problem (and having to change the name back after giving it).
- A better name for this function would be llRenameInventory (for which there is at least one JIRA).
Possibly should use key, not names source. And it should work as copy/rename/give function. In case of collision - either add number to it's name or return error (should be a flag parameter). --Zidan Foxdale 14:00, 20 June 2010 (UTC)