Taking snapshots

From Second Life Wiki

Second Life Wiki > Creation > Taking snapshots
Jump to: navigation, search

Torley's Guide to High-Quality Photography!

last revised by Torley for Second Life 1.20 — feel free to improve this page and add your own helpful notes!

Contents

Intro

The following covers what I do for beautiful inworld photography.

First, if you're not already familiar, a little about me (Torley Linden)... I won't bore you with formal credentials, but I will share my joy: before I worked for Linden Lab, I started Second Life as a Resident, and began taking snapshots on my very first day. I've also established the Snapshots & Postcards resource on this wiki which you can add your helpful resources to (please!), and over the last few years, I've taken well over 100,000+ pictures inworld — to the right are some of them.

These were taken with Second Life's WindLight atmospheric rendering, with no retouching after they were saved to disk. SEE MORE!!!!

What follows are my perspectives, founded and inspired by what I've learned along the way. I'm severely grateful to the many who've helped me become a better photographer; oodles of inspiration comes from an earlier guide which I believe was by Bub Linden... that I can't find at the moment (but if this was a doctoral thesis, I'd surely cite it).

If you've found any of this helpful and/or have suggestions on what more useful knowledge I can share with you, please let me know.

Essentials

You should know these first before continuing!

Saving a snapshot to disk

Literally, how you capture your memories. Watch this video tutorial to learn how:

So, there are two ways to do this within the viewer:

(1) File menu > Snapshot to Disk opens a window that lets you choose a filename and save the snapshot to disk. Any subsequent snapshots taken during a session will be saved directly, and you won't be asked to choose a name until you relog. This is good if you want to take many photos uninterrupted, not-so-good if you want to name each one along the way. Snapshots are numbered sequentially, so with the default name, it'd be "Snapshot_001", "Snapshot_002", etc. I use this simple method most often.

(2) File menu > Take Snapshot, or press the Snapshot button on the toolbar,

and click the "More >>" button to show advanced controls:

I use this for sending postcards, but it can also be used to "Upload a snapshot" directly to your inventory, or "Save snapshot to hard drive" like the aforementioned. Choosing this option opens a window containing controls to help refine your snapshot before it's saved. Some of them are beyond the scope of this guide, but I prefer:

  • "What size image do you need?" = "Current Window", the maximum viewable area.
  • All checkboxes from "Show interface in snapshot" to "Freeze frame (fullscreen preview)" unchecked, unless I have a specific need, e.g., taking photos of the user interface.
  • I also leave "Auto-snapshot" checkbox off.
    If you are taking a lot of photos at a single event though, "Auto-snapshot" is very cool: first shot, click "New Snapshot" and the preview shows in the menu which then stays open with the "Save" button highlighted. When you see another shot you would like to take, just press "Save" — that does 2 things at once: it saves the previous shot you took and takes a new shot. If you want to discard any shot, just click "New Snapshot" instead of "Save". Working this way at an event where things are moving quickly saves a LOT of time! -Tid Kidd

After a snapshot's saved to disk, you can do further things with it, like play with it in an image-editing program, upload it to a photosharing site, print it out, or archive it for keeps. You can even turn SL images into comics. USE YOUR IMAGINATION... this works pretty durn well for me. :)

Camera controls

These are must-knows for obvious reasons! How can you take pictures without knowing how to control your camera? Holding:

  • Alt and clicking something focuses it to the center of the screen.
  • Alt and dragging the mouse zooms the camera.
  • Alt-Ctrl and dragging orbits the camera.
  • Alt-Ctrl-Shift and dragging pans the camera.

Difficult concepts to explain in words, so try it for yourself!

If you're on a Mac, Alt = Opt (also marked Alt on newer Macs). For more info, see "PC and Mac shortcut key differences".

You can also use:

  • The directional arrow or WASD (with chat bar closed) keys instead of dragging the mouse.
  • View menu > Camera Controls — I highly prefer keyboard shortcuts in most cases, as I find them quicker.

Image:Camera_Controls.png

A combo of these will help get your shot framed as you please!

This stuff is also vividly illustrated in this video tutorial (don't worry that the user interface looks different, it uses the Dazzle skin):

Enable the Advanced menu

Press Ctrl-Alt-D on PC or Opt-Ctrl-D on Mac. You'll see a new menu at the top of your screen next to the Help menu: Advanced. Some options useful for snapshotting can be found within, as we'll see.

Maximize your Second Life window

I run Second Life in a window because full screen mode makes it hard to switch between open applications on my computer.

To enable this, go to Edit menu > Preferences > Graphics tab and check "Run Second Life in a window".

Make sure to maximize your window so it covers as much of the screen as possible. When you take a snapshot, it captures everything you can see in your SL window, so obviously, bigger is better — you can always crop/trim later, but you can't add missing details so easily; it's generally best to have extra material to work with, just like traditional photography.

Turn on the High-res snapshots option

And how? Easy! Advanced menu > High-res snapshots. Once that's enabled with an X next to it, all snapshots you save to disk will be 4x the viewable size: 2x the height, 2x the width. For instance, if your actual screen resolution is 1024x768, then the resulting high-res snapshot will be 2048x1536.

The "High-res snapshots" option only works if you use File menu > Snapshot to Disk. If you want high-res snapshots from the option-laden Snapshot Preview tool (File menu > Take Snapshot):

  • Under "What size image do you need?", select "Current Window".
  • Take note of those numbers, and multiply "Width" and "Height" by the highest multiple it will go under or equal to a maximum of 6016 pixels. So, if "Width = 1600" and "Height = 1200" or "1600x1200", then "3200x2400" would work, or even "4800x3600". The higher you go, the bigger the file, and the longer it'll take to save.
  • You don't have to adhere to strict proportions, but if you take a picture that doesn't match your aspect ratio, it'll end up squished/stretched. To avoid this, check "Keep specified aspect ratio".
  • Click "New Snapshot" (if "Auto-snapshot" isn't on) every time you make a change, to preview what your snapshot will look like before it's committed to your hard drive.
  • When you're happy, click Save.

Taking hi-rez snappies will momentarily freeze your computer, and in some extreme instances, may crash Second Life. Having both lots of RAM and a fast hard drive help here: I have 4 GB (~3 GB accessible under 32-bit Windows) and a 150 GB Western Digital Raptor, which is a speedy-but-somewhat-expensive HD. If you're serious about snapshots in the long run, you'll want proper equipment! Plus, image editing of big pictures will also tax your resources, so if you intend to post-process, make sure your computer's up to stuff.

High-res snapshots are suitable for print, which has a higher resolution than your computer screen can display. A good idea if you intend to make jumbo posters.

Another way to get high-res results is to take smaller pictures and stitch them into a panorama. Blessed you, I wrote a tutorial titled How to make a beautiful Second Life panorama in 15 minutes. This panorama of Prim Hearts is 7785x3357 at full size!

You can also view my gallery of panoramic creations for more inspiring works.

Set your Preferences > Graphics to the max

Second Life 1.19.1 and newer, powered by WindLight, has a greatly simplified Preferences > Graphics tab, and just 1 of them instead of 3. It includes presets controlled by a master slider so you can move many settings at once, and also override that with custom, finer-grained controls if you so desire. Basically, all you gotta do is move that slider to Ultra, and there, you're pretty much set for high-quality snapshots! :)

If you want more control, click the Custom checkbox to show all the options underneath.

Also remember this general principle: moving sliders all the way to the right, checking checkbox buttons, and selecting the lowest of radio buttons (those round ones you can only select one from a series of) will result in the highest quality, at the price of lower performance. That's what I generally do, but:

  • I keep Tree Mesh Detail in the middle unless I'm doing some special nature shots with lots of Linden foliage in them. I find it can induce too much of a performance hit and doesn't really make the overall scene look better from a great distance. Often, I prefer Resident-created trees, like some of the impressive sculptie ones I've been seeing lately at Straylight, Jaguar Creek, Siege Guild, and Lilith Heart's work. Don't be timid to explore new locations — remember, long-distance travel via teleportation is free in SL, make the most of it!
  • I don't bother moving the Flexible Mesh Detail slider; it's currently broken, I think. It should make flexiprims move smoother when it's all the way to the right, but I'm not noticing a difference in 1.18.3, and it looks like it's been this way for awhile.

Need more help? Watch this Graphics Preferences Guide video tutorial!

Turn on antialiasing and anisotropic filtering

Antialiasing smooths out jaggy lines. It affects just about everything you see inworld, and increases your overall immersive experience. Antialiasing is especially important when you want to capture fine details like avatars with intricate attachments. On lower-end graphics cards, antialiasing will have a noticeable performance impact, especially at higher-quality modes. But on mid-range and particularly high-range cards — I currently (2007-10-30) have an NVIDIA GeForce 8800GTS. — you can crank it all the way up.

Also make sure in Second Life, Preferences > Adv. Graphics' "Anisotropic filtering" is on. A layman description: anisotropic filtering makes stuff at angles in the distance look sharper.

In Second Life 1.20 and newer, you can adjust antialiasing within Second Life:

  • Go to Preferences > Graphics tab.
  • Click Hardware Options.
  • Boost antialiasing as you please, but be aware higher settings will be slower because it renders the scene at multiples of itself before downscaling. More powerful graphics cards will be able to do higher-quality modes (e.g., 16x).

You can also adjust antialiasing within your drivers.

I'm mostly familiar with NVIDIA cards, and in Windows XP with recent drivers:

  • Go to Control Panel > NVIDIA Control Panel.
  • Expand "3D Settings" and select "Adjust image settings with preview".
  • Click the "Use my preference emphasizing" button.
    • The quickest way to get results is to move the simple slider all the way to the right — "Quality".
    • If you're feeling adventurous and know what you're doing, after selecting Quality (which changes a whole bunch of micro-settings), select "Use the advanced 3D image settings".
    • You can keep most of these settings how they are; you'll generally want to set both "Anisotropic filtering" and "Antialiasing - Setting" as high as possible — mine are at 16x, but the maximum will depend on your hardware.
  • After setting this, try running Second Life and see if you can tell the difference, both in terms of visual quality and performance. Even 2x is noticeably better than having none on at all.

I reckon the process is similar for ATI cards; if someone wants to help me fill in the details, please do!

What if doing the above makes Second Life too slow?

Aw. :\ Well, if that's the case, have comfort that you can change the aforementioned options back to more moderate settings. I sometimes crank up settings extremely high for the purpose of taking snapshots, then move them back down after a photo session is done. While it may be clunky to twiddle with all the custom sliders & buttons, you can use the master slider (Low, Mid, High, Ultra) for one-click settings.

More useful skills to have

Some of the following is covered in this video tutorial:

Use keyboard shortcuts

Whenever possible, I use keyboard shortcuts to save time. Each appropriate menu item has its shortcut listed next to it. For example, "Snapshot to Disk" is Ctrl-`. You can press that rapidly from the keyboard to take a sequence of many snapshots, then discard the ones you don't like later.

You'll find over the long run that using shortcuts is far advantageous to repeatedly reaching for the menus, and wasting your energy. (As I like to say, "economize your moves!") Shortcuts can take awhile to get used to, so don't worry if they feel awkward at first — and the best way to build a good habit is to use keyboard shortcuts regularly and often.

Changing time of day

You can locally (meaning only you will see the changes) change the time of day anytime you wish:

  • World menu > Environment Settings.
  • Select either Sunrise, Midday, Sunset, or Midnight.
  • World menu > Environment Settings > Revert to Region Default will get you back to how things used to be, or you can relog.

Watch this video tutorial to learn more:

Zoom In & Out

These are very useful options which surprisingly aren't more obvious: View menu > Zoom In and Zoom Out. You can use each multiple times — Zoom In 13 times, Zoom Out 6 times — to increase the magnitude of zoom.

Zoom In is useful for when you have problems getting closer to specific subject matter, altho if you zoom in very close, you may feel like a sniper/voyeur.

Zoom Out is great for wide-angle vantage scenes, like certain kinds of panoramas, or when you're trying to cover a city that spans a whole region in one shot. Instant drama of the good variety.

Be careful, tho: if you use Zoom Out 6 times, the screen will look like something out of a Star Trek warp speed scene! Just go to View menu > Zoom Default to reset at any time.

Watch this video tutorial to learn more:

Disable Camera Constraints

Ever wanted to take an epic shot of vast scenery but were frustrated you couldn't move your camera far enough to capture it all? There are a couple things you need to do:

  1. Edit menu > Preferences > Graphics tab and set Draw Distance to at least 128 m. I even set mine to 256, or even 512 to see really far away. With higher draw distance, you can move your camera further.
  2. Advanced menu > Disable Camera Constraints. You'll notice with the (see Camera controls), you can "grab" the terrain much further.

Watch this video tutorial to learn more:

Advanced lighting

If your computer meets our System Recommendations, you should be able to turn on local lighting. Preferences > Graphics tab and select "Nearby local lights". If you don't see this option, click the "Custom" checkbox.

In addition to backlighting from the sun & moon, the 6 nearest lights (if you're curious, it's an OpenGL limit) will cast light on avatars, objects, and terrain within their proximity. Like "First Life" photography, well-placed lights can add contrast, tone, and depth to a scene. For example:

<— Local Lighting OFF

<— Local Lighting ON

You can even create transparent objects that illuminate what's around them, and some Residents have gone so far as to create their own "personal lighting" gadgets with elaborate controls, like the Luxace.

For an animated video showing how to create a basic personal light, watch the tip @ 2:36 of this video.

Quiet Snapshots to Disk

If you get annoyed at the whirrrr-click! that happens whenever you take a snapshot and others complain that you sound like a tourist (it's happened to me!), you can disable that sound and animation. Go to Advanced menu > Quiet Snapshots to Disk — it does what it says! However, there is a bug (VWR-2448 on our Issue Tracker): it only affects File menu > Snapshot to Disk, and not File menu > Take Snapshot (where the Snapshot Preview palette comes up).

There's a workaround, tho: Advanced menu > Debug Settings, and in the top text field, enter "UISndSnapshot". In the bottom, erase the "3d09f582-3851-c0e0-f5ba-277ac5c73fb4" so it's blank. You'll still animate when snapshotting, but it'll be silent. If you ever want your snapshot sound back, just click "Reset to default".

Hide the User Interface

Framing matters a lot, and it's normal in Second Life to have a clutter of windows blocking parts of your screen as you're taking snapshots. Sure, you can close them, but it's inconvenient to reopen and close them time and time again, especially if you routinely have many. And even if you don't have any windows open, the top menu bar and bottom toolbar will likely be blocking small horizontal strips of your total viewable area.

So, what to do? Easy!

I often use Advanced menu > Rendering > Features > UI to have a "clean" view of Second Life before taking a snapshot. I actually use its equivalent shortcut, Ctrl-Alt-F1, to save time. The cool thing is, after taking a snapshot, the UI (User Interface) will automatically show again.

The UI is just hidden when you do that, and the windows aren't physically moved off the screen a la Mac OS X's Exposé, so you can actually still click buttons and other things if you aren't careful — keep that in mind!

Note, if F1 doesn't work for you, make sure F-Lock is ON.

Special Debug Settings

The following applies to Second Life 1.19.1 or newer. Also note that you may want to remember to turn them off after your snapshotting is done — some may have undesirable effects and/or too much of a performance impact in regular usage.

These Debug Settings are useful for increasing visual quality at the cost of performance. They're not directly accessible from the usual places in the user interface (e.g., Preferences), and are sort of "secrets". Aren't you glad you're reading this so you know this?

To access any of these, go to Advanced menu > Debug Settings and type the setting's name in the top box and press Enter. You'll see its parameters appear, and some help text to guide you on your way.

Special thanx to Runitai, Brad, and BigPapi Linden for cluing me in:

RenderDynamicLOD

Set it to "FALSE" to reap the benefits. I primarily use this because it makes far-away terrain look more organic and natural. LOD stands for "Level Of Detail". Try going to a place rich in terraformed hills, valleys, and other geographical features and compare.

RenderFarClip

This is also known as "Draw Distance", but the advantage of setting it here is that you can boost it to extreme numbers like "2048.000" (that's meters, folks!), which will also result a huge performance impact. For laughs, try setting it to something short like "32.000" and you may find an artistic use for the premature clipping. I like setting this real high and moving my camera far above a cityscape to see all the tiny details within. See example.

RenderUseFarClip

If you set this to "FALSE", performance will decrease because objects past the far clip plane will be drawn. Good to use in combination with a reasonably long draw distance, as it preserves more stuff in the distance. Again, this is worthwhile to experiment with and see what it does for you. I do many of my grand panoramic vistas with this on "FALSE".

RenderGlowMinLuminance

Lower this to about "0.250" or so to achieve full-scene glow — it looks ethereal and dreamy, like a wedding photo! If highlights get too washed out, go to the Advanced Sky Editor > Lighting tab and lower Gamma to compensate.

HUD objects can also have glow, so overlaying an HUD object atop the whole screen is an alternative way to do this.

Built-in artistic effects

While this guide doesn't endeavor to cover all myriad possibilities, you may want to explore these...

Wireframe

Instant cyber-vision! Advanced menu > Rendering > Wireframe shows you a bare-bones view that may remind you of such flicks as The Matrix and The Thirteenth Floor:

Intriguing things can happen when you take pictures of a normal scene and its wireframe counterpart, then composite them, as shown here.

"Depth" and "Object Matte" capture modes

These are accessed through the Snapshot Preview tool when you select "Save snapshot to hard drive" (it's not enabled with "Send a postcard" or "Upload a snapshot") and next to "Capture", change "Colors" (the "normal mode"):

<— Colors (normal mode)

<— Depth

<— Object Mattes

Both are useful for layering post-processing in an image editor, where for example, you can selectively apply a zoom blur depending on the depth of the scene.

Depth is also very handy for taking silhouette-esque shots, like Noelani Lightfoot's "Treehouse" and Syene's "Gallery Space".

Object Mattes may look like a TRON-ish array of blue and green splotches at first, but it is useful for masking and distinguishing individual objects for precise manipulation. Fianna Idora's "Matte Profile" and Melanie Kidd's "me and ary" are good examples of how it can be used artistically.

Alternatively, Advanced menu > Rendering > Info Displays > Pick Render also shows object mattes, and this method's advantage is you can include it in postcards and uploaded photos without any intermediary steps. Thanks for the tip, Lyndyn Tzara!

You can combine Depth and Object Mattes with the aforementioned Wireframe mode too.

I've just scratched the proverbial surface here, so go wild with your creative instincts and show me what you come up with!

Related resources

Snapshots & Postcards

^ Check out dat page for more of "the good juice".

Also watch the related video tutorial on how to send a postcard from Second Life to an email address:

Joystick Flycam

This must be one of the bestest "hidden features" EVAR. The Flycam is useful for cinematic, smooth, and other sorts of tracked shots in machinima, but it can also assist you in positioning your camera for still shots. If you have a capable joystick or other input device, this is well-worth checking out. As of Second Life 1.20, we have formal support for 3Dconnexion's SpaceNavigator 3D mouse:

Watch more video tutorials on how to use it.

Misc. tips

Did you know you can:

  • Save textures to your hard drive? For example, if you've uploaded snapshots to your inventory, this lets you export them so you can upload them to other sites and post them outside of Second Life. You can do this by opening a texture with full permissions and going to File menu > Save Texture As — see the link for further details.
  • Hide foot shadows? Advanced menu > Rendering > Features > Foot Shadows

A state of snapshots

^ Torley's personal notes on how things've come to be.

Read up on non-SL photo tips

I find inspiration in our analogue world, and while some things like exposure and aperture settings don't exactly correspond to SL's somewhat-limited built-in snapshot tools, you can still learn a lot — plus, due to the magic of post-processing, you can bring your SL snapshots into Photoshop or another image editor and make them look worn, frayed, and more organic.

I check popurls daily, not just for photog tips but because of the sheer amount of useful + fun headlines that come up. It's a mega-aggregator of many useful sources.

I also dig Lifehacker's Photography section a lot, which also regularly highlights programs that you can use on your pictures. Make it a good habit to check these resources at least every few days, and stick with it for at least a month so you've established familiarity with what's out there. I've learned a lot doing this.

Learn about things like the "rule of thirds" so you know how to break 'em later. ;) It may sound philosophical, but by knowing your limits and knowing what's already been done, you're freeing yourself to explore, to venture further — into the "unknown" of your creative space, and express yourself as you truely see fit.

I wish you all the best in photographing your Second Life!

Personal tools
In other languages