From Second Life Wiki
Revision as of 06:01, 29 May 2007 by Eraz Rhode (Talk | contribs)

Jump to: navigation, search

Name of Function

Maybe, to match the current nomenclature of LSL, this should be called "llGetOwnerAccountBalance" or "llGetOwnerMoney"
Cron Stardust 14:25, 21 March 2007 (PDT)

Possible security issues

I just noted that with this function it would be possible to detect when the owner paid money to another person/object or received funds by recording the current amount of money, then testing again after a period of time and comparing the values. This would allow a malicious script to siphon money away from the owner to another player slowly and at each transaction so as to hide traces of it's activity.
Cron Stardust 14:25, 21 March 2007 (PDT)

Security issues from scripts within vendor machines etc.

Such functionality will bring new security issues. Vendor software, which is often not editable by customers using them, might contain spyware functionality to spray account balance information around in SL and into the internet. This is a seriuos issue related to privacy!