Debug Help/es

From Second Life Wiki
Jump to: navigation, search

Esta página está pendiente de ser traducida al español.

Al no estar reflejada en la página del Proyecto de Traducción del wiki, es importante que si usted empieza a traducirla lo indique aquí para evitar que otro usuario realice un trabajo baldío:


Una vez traducida la página, por favor, borre este texto.

This page's purpose is to make it easier for you to provide us with info to help fix bugs. You may be asked for the following details by a Linden so we can help you further, so bookmark this for future reference.

How do I send crash logs?

This can be done automatically. In Second Life, Preferences > General tab > Crash reports should be set to "Always send" or "Ask before sending".

Note that when the Crash Reporter is active, it may go slowly as it sends us your info. This is normal.

How do I find my system information?

This info is used in the Issue Tracker's Environment fields, and there are a couple ways to get it:

  • Start Second Life.
  • On the login screen, click Preferences button.
  • Click the About button.
  • You'll see the About Second Life window containing your system information on the top pane. (Note that ironically due to a bug, the internal-only SL-37394, you can't copy and paste this info.)

If you're able to login to Second Life, then:

  • Start Second Life.
  • On the login screen, click Connect button.
  • When inworld, go to Help menu > About Second Life.
  • You'll see the About Second Life window containing your system information on the top pane. Copy and paste the whole thing into an issue. It'll look like this:
About Second Life - 1.17.2.png

Where do I find my SecondLife.log file?

IMPORTANT: This log contains your computer's system info and some local directory paths. It does not contain any personal/private account data, but if you feel uncomfortable providing the aforementioned publicly on the Issue Tracker, say so in the corresponding issue's comments in order to facilitate a Linden receiving it privately.

On Windows, it'll usually be in a directory like this ("username" refers to the one used to identify you on your computer, not your Second Life Resident name):

C:\Documents and Settings\[YOUR USERNAME]\Application Data\SecondLife\logs

Your drive letter may vary depending on your setup, but C: is the most common. To get here, you can also click the taskbar's Start button > Run, then next to "Open:" type "%appdata%" and click OK. Scroll down and look for the "SecondLife" folder, then inside that, open the "logs" folder.

On a Mac, it'll usually be in a directory like this:

/Users/[YOUR USERNAME]/Library/Application Support/SecondLife/logs

On Linux, the secondlife.log file is located on Linux in:

~/.secondlife

where ~ is your home/user directory.

How do I get my Fast Timers results?

Fast Timers are a set of scrolling bars which separate Second Life's resource usage into colored chunks. This is very useful for identifying if a certain category is using far more computer power than it should, and helps us pinpoint problems. It may look overwhelming at first, like something out of Star Trek, but as long as you can take a good screenshot and send it to us, that's what matters.

First, you'll need the Client menu on. Press:

  • Ctrl-Alt-D on Windows and Linux.
  • Opt-Ctrl-D on Mac.

You should see it appear in the menu bar, to the right of the Help menu. (On some systems, you may need to press Ctrl-Alt-Shift-D.)

Once it's open, go to Client menu > Consoles > Fast Timers. Like this:

Client menu - Consoles - Fast Timers.jpg

You should see the bars appear, with an animated line graph below.

Fast Timers.jpg

Each bar corresponds to a frame, so if your performance is slow, the bars will animate slowly too. (You can try going to a busy area with many avatars and compare that to being in a quiet place with no one else around.)

Feeling dizzy? Click on or near the bars to freeze the chart.

You can click on labels to expand/contract them and show a more detailed breakdown, which Lindens may ask you to do depending on the situation. For example, if you click twice on "Render" — once to hide, once to open — it goes from this:

Fast Timers - Render - closed.png

to this:

Fast Timers - Render - open.png

This shows a breakdown of what's using the most "Render" time, which is helpful in diagnosing graphics-related slowdowns.

Then, you can do the next step, which is to take a screen capture. There are a number of ways to do this:

Using Second Life's built-in tools

  • Click Snapshot button on the toolbar.
  • Click "Save snapshot to hard drive".
  • Check "Show interface in snapshot".
  • Click "New Snapshot". You should see a little preview which shows the Fast Timers.
  • Click Save button. The first time you do this during a session, it'll ask you where you want to save the picture. Go ahead and save it somewhere you'll remember.

Using external tools

No matter what method you use, the important thing is making sure the whole Fast Timers are clearly visible.

Next, if you saved the file as a BMP, TIF, or another large filetype, you'll want to compress the image into a web-friendly format to get a good balance of detail and filesize. This can generally be done like this:

  • Open the file in the image editor.
  • Go to File menu > Save As.
  • Select "JPG" as format. You may may see an additional option to choose quality — preferably, the compressed image should be less than 500 KB, so aim for about 50-75% quality.

If you're not sure what to use, try free XnView on Windows or Preview on Mac.

Attaching the screenshot to an issue

Our Issue Tracker allows you to attach images to an existing issue. If they're in a web-friendly format like JPG, there'll also be thumbnail previews for convenience. See an example.

VWR-1478.png

All you have to do is:

  • On the left side, click "Attach file to this issue". A form will appear.
  • Click Browse button and locate the image where you saved it.
  • Enter a comment as appropriate — it could simply say, "Here are my Fast Timers results.", and click Attach button.
  • Wait a few seconds, and if it succeeded, you'll end up back on the issue's main page, now showing your attached Fast Timers screenshot.

For power users

If you know what you're doing, you don't even have to save to disk: a much quicker way is to capture the screen to clipboard, then on the issue's main page, click "Attach screenshot to this issue" and click Paste button. It should appear in the preview box, then you can customize the file name, make a comment, then attach it.

Related, see JIRA maker Atlassian's documentation.

We've also got a more comprehensive and technical explanation of Fast Timers. Learn more.