Déménager vos constructions

From Second Life Wiki
(Redirected from Move build/fr)
Jump to: navigation, search

Ce guide vous montre comment déplacer vos constructions, maison ou magasin, par exemple, d'une parcelle de terrain dans une région vers une autre. Il suppose que vous savez comment bouger votre caméra et éditer des objets. Prenez votre temps, profitez des vidéos, et faîtes attention à tous les détails pour que rien ne soit perdu. Ce guide se concentre principalement sur le déplacement de constructions grandes et complexes mais le principe s'applique à des constructions de toutes les tailles. Apprenez-le bien pour bien le comprendre avant de vraiment faire le déplacement.

Emblem-important-red.png Warning!

Important : La plupart des vidéos ont été filmée dans le client Second Life® 1.23 ou ultérieur. Vous "devez" utiliser cette version pour voir certaines fonctionnalités telles qu'elle sont présentées, comme par exemple, le décompte des primitives. Également, si vous lisez ce guide dans le navigateur intégré de Second Life, les vidéos n'apparaîtront pas. Chargez la page dans un navigateur externe si vous voulez les voir.

Avant de déménager

  • Vérifiez que la parcelle de destination ait au moins la même surface que celle que vous quittez - La capacité en primitives d'une parcelle est liée à sa surface. Si ce n'est pas le cas et que le quota de primitives de votre parcelle d'origine était atteint, vous risquez de ne pas pouvoir mettre tous vos objets sur la nouvelle parcelle.
  • Familiarisez-vous avec la forme de la parcelle de départ et de celle de destination - si elles ont une forme similaire - par exemple les deux sont carrés - la transition sera facilitée. Observez également le terrain — si la parcelle de départ est escarpée et que celle de destination est plate, vous devrez terraformer cette dernière pour qu'elle corresponde à la première. Autrement, vous devrez peut-être reconsidérer la position de certains objets.

Enregistrez la configuration dans À propos du terrain

Chaque parcelle vous appartenant a ses propres réglages; si vous possédez plusieurs parcelles, la configuration de chacune d'entre elles devra être enregistré séparément.

Il existe de nombreux moyens pour enregistrer la configuration d'une parcelle : vous pouvez utiliser les fonctions de capture d'écran de votre système d'exploitation, tel que le Snipping Tool sur Windows Vista ou Capture sur un Mac. C'est un bon moyen pour enregistrer des images de vos paramètres. Cette méthode présente toutefois le désavantage de vous obliger à retaper tout le texte.

Vous pouvez aussi utiliser un éditeur de texte externe tel que Wordpad sur Windows ou TextEdit sur un Mac, mais si vous trouvez ça trop lourd, Second Life dispose de notecards intégrées. Voici comment en créer une :

  1. Cliquez le bouton "Inventaire" sur la barre d'outil en bas à droite de la fenêtre du client.
  2. Dans la fenêtre de l'Inventaire utilisez Créer > Nouvelle note.
  3. Renommez la note en utilisant le nom de la parcelle pour la trouver plus facilement après.
  4. Cliquez deux fois sur la note pour l'ouvrir. C'est un simple éditeur de texte.
Notecard FTW-fr.png

Avant de commencer, décidez si vous voulez enregistrer les paramètres de votre parcelle dans une notecard ou avec un éditeur externe. Ouvrez celui que vous avez choisi pour être prêt(e) à coller les paramètres dedans. Voici maintenant comment vous enregistrez vos paramètres :

  1. Emmenez votre avatar sur la parcelle concernée. Vous verrez son nom au milieu de la barre de menu.
  2. Allez dans "Monde" > "À propos du terrain".
  3. Cliquez sur l'onglet Général (si il n'est pas déjà sélectionné).
  4. Sélectionnez le nom de la parcelle avec votre souris.
  5. Utilisez "Édition" > "Copier" pour copier le nom (ou le raccourci Ctrl-C/"Cmd-C").
  6. Cliquez dans la notecard ou dans l'éditeur de texte externe.
  7. Utilisez "Édition" > "Coller" (Ctrl-V/ "Cmd-V").

Répétez les étapes de copier/coller pour tous les paramètres de la parcelle que vous souhaitez transférer. Notez que certains, par exemple le "Lieu d'arrivée" dans l'onglet Options, ne s'appliqueront pas à la nouvelle parcelle (dans ce cas, à moins que la parcelle de destination n'ait les mêmes coordonnées relatives à la région).

Modèle

Pour vous faciliter la vie, voici un modèle que vous pouvez copier directement dans une notecard ou un fichier texte pour les remplir ensuite. Adaptez-le à vos besoins.

Astuces pour déplacer vos objets

Conseils préparatoires

La capacité à faire bouger votre caméra est très importante, car les objets dans Second Life sont en trois dimensions et il est facile de rater ce qui peut être caché derrière un mur visible uniquement sous un certain angle. Apprenez-en plus avec cet article "How do I look at something from a different angle?" (anglais)

Apprenez comment sélectionner les objets, soit en cliquant sur eux en même temps que vous pressez sur la touche Maj, soit en dessinant un rectangle de sélection :

Paramétrez les options suivantes pour simplifier le processus de manipulation et de prise de vos objets :

  1. Ouvrez le menu Édition > Préférences.
  2. Cliquez sur l'onglet Graphiques et cochez "Personnalisé". Augmentez la limite d'affichage à au moins 128 m. Si vous avez un ordinateur puissant, vous pouvez augmenter cette limite, mais assurez-vous que les performance n'en pâtissent pas — un taux d'images faible accroît la difficulté de sélection des objets.
  3. Paramétrez le détail des rendus des Objets sur High (en bougeant le curseur complètement à droite) pour vous aider à identifier visuellement ce que vous sélectionnez.
  4. Vous pouvez décocher "Reflets de l'eau" et "Effets atmosphériques" pour améliorer les performances. Ces effets rendent les objets plus jolis, mais un aspect plus basique facilite leur manipulation.
  5. Cliquez sur OK pour enregistrer les paramètres.

Si vous voulez voir où se termine votre parcelle et où celles des autres commencent :

  1. Activer le menu Affichage > Limites des parcelles pour afficher les limites de votre parcelle.
  2. Activer Affichage > Propriétaires fonciers pour ajouter un couche colorée au-dessus des parcelles. Les parcelles qui vous appartiennent sont de couleur verte, celles qui appartiennent à des groupes de couleur bleue, celles qui appartiennent aux autres de couleur rouge.
OMG land colors-fr.png

Aussi, dans le menu "Outils" :

  1. Activer "Outils" > "Sélectionner mes objets uniquement".
    • Si vous déplacez une construction créée de manière collaborative, contactez tous ceux qui ont participé et montrez leur ce guide pour comprendre tous ensemble ce qui doit être fait.
  2. si vous avez des problèmes lors de la sélection d'objets plus grand, désactivez "Outils" > "Sélectionner en entourant". Si vous avez du mal à sélectionner des objets plus grands, désactivez Outils > Sélectionner en entourant. De cette façon, un rectangle de sélection sélectionnera un objet dés qu'une petite partie de celui-ci sera couverte.
  3. Si les contours d'un objet vous empêchent de bien voir ce que vous sélectionnez, désactivez Outils > Afficher les parties cachées de la sélection pour améliorer les performances, car la sélection de beaucoup d'objets avec des contours complexes est lente. Vous devrez peut-être laisser ce paramètre activé si vous sélectionnez une construction contenant des objets, comme une maison contenant beaucoup de meubles.

Options du menu Advanced

Nous ne supportons pas officiellement ces fonctionnalités, mais elles peuvent beaucoup vous aider si vous en avez l'habitude. Si vous n'êtes pas sûr, familiarisez-vous dans un bac à sable publique pour éviter de détruire vos objets.

  1. Apprenez comment activer le menu Advanced.
  2. Activez Advanced > Disable Camera Constraints (la version 1.23 ou ultérieure n'est pas nécessaire) pour augmenter la distance jusqu'à laquelle vous pouvez zoomer en arrière avec la caméra. Utile pour obtenir une "grande image" d'une grande construction.
  3. Désactivez Advanced > Limit Select Distance pour sélectionner les objets dans le lointain, facilitant ainsi la sélection d'objets sur de très grands terrains.
  4. Si certains de vos objets sont soit partiellement soit complètement immergés, désactivez Advanced > Rendering > Types > Water pour cacher l'eau et pouvoir les sélectionner sans qu'ils soient masqués. Regardez une vidéo de démonstration :
  5. Si nécessaire, désactivez Advanced > Rendering > Object-Object Occlusion. Techniquement parlant, l'occlusion culling augmente les performances en ne produisant pas de rendu pour les objets que vous ne pouvez pas voir en se basant sur un octree, mais, suite à cette manipulation, il peut s'avérer, dans certains cas, plus difficile de sélectionner globalement des objets. Comme indiqué, désactiver l'occlusion culling diminue les performances, donc, rappelez-vous de le réactiver une fois le déplacement effectué.

Astuces pour optimiser vos objets avant de les prendre

  • Assurez-vous de déverrouiller tous les objets avant de les prendre - Rezzer un seul objet verrouillé en même temps que beaucoup d'objets déverrouillés empêche la sélection entière de pouvoir être déplacée en un seul morceau— les flèches flèches de positionnement ne s'afficheront pas. Cela peut entraîner la déselection de tout l'ensemble, ce qui est difficile à recommencer. Voici comment déverrouiller des objets :
    1. Entrez en mode Édition (rappelez-vous, Outils > Sélectionner un outil > Éditer ou Ctrl-3!).
    2. Dessinez un rectangle de sélection autour d'autant d'objets que possible.
    3. Cliquez sur l'onglet Objet" dans la fenêtre d'Outils.
    4. Si un ou plusieurs objets sont verrouillés, Verrouillé sera coché et grisé. Cliquez une fois sur Verrouillé pour verrouiller tous les objets, attendez un moment si il s'agit d'un nombre important d'objets, puis cliquez une autre fois. Si tous les objets de la sélection sont verrouillés, la case sera cochée et active et n'aura besoin d'être décochée qu'une seule fois pour déverrouiller tous les objets.
    5. Sélectionnez une nouvelle fois les objets pour vérifier qu'ils sont tous déverrouillés. La case à cocher Verrouillé doit être décochée.
    6. Si vous n'avez pas déjà sélectionné tous les objets sur votre propriété, répétez les étapes précédentes pour vous assurer que tout est déverrouillé. Des passages consécutifs peuvent aider à vérifier que vous n'avez rien oublié la première fois (par exemple, une lampe dans une petite pièce).

  • Lier autant d'objets que vous pouvez - C'est spécialement vrai si vous avez créé les objets et/ou avez toutes les permissions sur eux. Ne liez pas différents objets scriptés entre eux car cela pourrait poser des problèmes avec leurs fonctionnalités (par exemple, lier un télévision avec un lit pourrait mélanger leurs fonctionnalités et provoquer des dysfonctionnements), mais vous pouvez tranquillement lier le plupart des structures basiques, telles que les murs ou les toits, proches l'une de l'autre. Lier est également important car il facilite le positionnement des objets après les avoir rezzé (pour éviter d'abîmer par inadvertance le sol d'une maison, par exemple).
  • Donnez à vos ensembles d'objets liés des noms bien choisis - Des objets nommés "Object" dans votre inventaire vous causeront des problèmes inutiles, car vous devrez les rezzer pour savoir ce qu'ils sont — ce qui représente à la fois une perte de temps et d'espace. Nommez chaque objet de manière descriptive "avant" de le prendre.
  • Utilisez un script pour rezzer les objets - L'utilisation de scripts tels que Rez-Faux, Ilse's Big Build Rezzer, et autres sur Xstreet ou le Kit des créateurs du groupe Constructeurs et Scripteurs vous permet d'empaqueter un ensemble d'objets et de les positionner soigneusement après les avoir rezzé. Le mode d'emploi de chacun des scripts est différent et ils ne fonctionnent que si les objets sont modifiables, mais il est intéressant d'y jeter un coup d'oeil, car ils vous évitent pas mal de problèmes.

Les arbres Linden

Les arbres Linden font partie des feuillage fournis par le système et listés dans votre Inventaire dans le dossier Library > Objects > Trees, plants and grasses. Ils ont un certain nombre de faiblesses, dont celle de ne pas apparaître en surbrillance lorsqu'ils sont sélectionnés. Ils ne peuvent également pas être liés à d'autres objets, les rendant ainsi plus difficiles à transporter, bien qu'ils puissent être inclus dans un aglomérat d'objets. Regardez cette vidéo pour comprendre ces problèmes :

Objets invisibles

Ne les oubliez pas ! Les objets tels que les compteurs de visiteurs ou les générateurs de sons d'ambiance peuvent être invisibles. Certains d'entre eux sont scriptés de façon à apparaître sur commande. Consultez la documentation de chacun d'entre eux pour savoir. Si vous ne pouvez pas vous rappeler où vous les avez laissés, Affichage > Voir les objets invisibles va vous les montrer. De la même façon, mais à un degrés moindre, Voir les objets invisibles vous aidera aussi à trouver les objets partiellement invisibles, tels que les rayons de lumières et les vitres de fenêtres ayant une texture.

Affichage > Balises peut situer d'autres types d'objets spéciaux. Apprenez-en plus.

Skyboxes

Stylish-skybox.jpg

Vous devez connaître certains éléments avant de bouger les constructions situées très haut dans le ciel et souvent appelées "skyboxes" :

  • il est plus facile de sélectionner votre skybox qu'une construction sur le sol - Comme l'espace tend à être de moins en moins encombré au fur et à mesure que vous montez, vous avez des chances de voir votre construction comme une collection d'objets isolés au lieu qu'elle soit très proche des constructions voisines.
  • Vous ne pouvez pas facilement voir les limites de votre terrain quand vous êtes des milliers de mètres en l'air - Quand vous êtes sur la parcelle que vous quittez et sur la parcelle de destination, prenez les coordonnées du centre :
    1. Soyez au niveau du sol.
    2. Déplacez votre avatar au centre de la parcelle.
    3. Voyez au milieu de la barre de menu du client les deux premières coordonnées. Par exemple, "Yendra 34, 54".
    4. Notez les et envolez-vous.
  • Équipez-vous d'un assistant de vol - Cela vous permet de voler haut sans que votre avatar ne retombe régulièrement. Si vous avez déjà construit dans le ciel, vous devez déjà en posséder un. Sinon, cherchez sur Xstreet.
  • Vous devrez probablement rezzer sur le sol une plate-forme pour vous guider. - Vous ne pouvez pas rezzer d'objets dans l'air en les sortant simplement de votre inventaire. À moins que vous ne disposiez d'outils spéciaux, vous devrez les rezzer près d'objets qui existent déjà. Voici comment :
    1. Rezzez un cube à côté du centre de votre parcelle de destination.
    2. Redimensionnez-le à 10x10x0.5 m ou toute autre dimension qui correspondent à vos besoins. Vous pouvez avoir intérêt à utilisez des megaprims si votre skybox est grand et que vous devez le rezzer en plusieurs morceaux ou vous préférerez peut-être rezzer plusieurs prims pour avoir une idée générale de la position de vos bordures. (Vous pouvez aussi le savoir en regardant la barre de menu : si les infos deviennent celles de la parcelle d'un voisin quand vous marchez ou volez, vous êtes manifestement passé au delà des limites..)
    3. Asseyez-vous sur ce prim.
    4. Cliquez droit et sélectionnez Éditer... dans le menu contextuel.
    5. Dans l'onglet Objet, changez les coordonnées Z pour celle de la hauteur souhaitée de votre skybox et pressez sur Entrée. Vous serez ainsi transporté quasi instantanément dans le ciel.
    6. Cliquez sur le bouton Me lever en bas de votre écran.
    7. Essayez de déposer un objet de test (et "pas" votre skybox) à partir de votre inventaire. Notez comment le curseur change pour montrez que vous pouvez "rezzer" quand vous le positionnez au-dessus d'un autre objet. Prenez un moment pour vous entraîner.
    8. Suivez les conseils généraux ci-dessous pour rezzer des objets, mais soyez conscient que les limites de votre parcelle ne sont pas facilement visibles dans le ciel.

Entraînez-vous à prendre des objets

Ré-assembler des morceaux d'un objet sera comme un puzzle et vous aurez intérêt à concevoir un plan que vous pourrez suivre.

  1. Nettoyez le dossier Objets de votre inventaire. Les nouveaux objets que vous prenez finissent ici, aussi rangez les autres objets dans des dossiers ou des sous-dossier pour ne pas être distrait.
  2. Entrez en mode Édition : cliquez droit sur un objet et sélectionnez Éditer... dans le menu contextuel ou utilisez Outils > Sélectionner un outil > Éditer.
  3. Cliquez droit sur l'onglet à tester. Ses bords seront surlignés (en jaune, pour la prim racine, en bleu pour toutes les autres).
  4. Cliquez et faîtes glisser votre curseur pour sélectionner plusieurs objets.
  5. Une autre façon : essayez de garder la touche Maj. enfoncée tout en cliquant sur plusieurs objets.
  6. Notez que la fenêtre d'Outils indique combien d'objets sont sélectionnés et combien de combien de prims (primitive, objets uniques) ils sont composés.
    • Essayez de garder une petite taille à vos lots. Vous ne pouvez pas sélectionner plus de 4000 prims car nous avons constaté qu'un nombre supérieur a de fortes chances d'entraîner une erreur. Comme il a été décrit plus tôt, sélectionner beaucoup d'objets abaisse les performances car toutes leurs bordures surlignées doivent être rendues. De plus, rezzer en une seule fois beaucoup de prims dans une région peut causer des ralentissements significatifs, avec une fiabilité amoindrie.
  7. Rezzez quelques cubes ou un petit nombre d'objets auquels vous ne tenez pas et essayez de les sélectionner et de les prendre tous en une seule fois.
  8. Vous les verrez apparaître dans votre inventaire avec une icône spéciale ressemblant à des "bloc empilés" (souvent appelée par certains le "Rubik's cube cassé"). Il s'agit d'un groupe d'objets.

Attention aux problèmes liés aux groupes d'objets

Les groupes d'objets sont très utiles, mais ont un certains nombre de défaut qui incluent la possibilité de perdre des objets. Aussi pratiques qu'ils puissent être pour des constructions complexes, minimisez l'utilisation des groupes d'objets à moins que vous ne vous soyez beaucoup entraîné avec. Lisez see "Inventory: How the Coalesce feature works" pour plus d'informations.

Prenez vos objets

Êtes-vous prêt ? Le grand moment est arrivé. Espérons que vous vous êtes bien entraîné et que vous êtes habitué à prendre et rezzer des objets d'un endroit à un autre. Voici les étapes que vous répétez pour chaque objet ou groupe d'objets d'un emplacement à un autre :

  1. Entrez en mode Édition : cliquez droit sur un objet et sélectionnez Éditer... dans le menu contextuel ou utilisez Outils > Sélectionner un outil > Éditer.
  2. Cliquez et faîtes glisser le curseur de la souris ou cliquez en maintenant la touche Maj. enfoncée sur les objets liés à proximité. Par exemple, un bureau et un ensemble de chaises.
  3. Déplacez votre caméra autour des objets pour vous assurer que vous n'avez pas laissé de côté une ou plusieurs partie(s) importante(s). Si c'est le cas, recommencez la sélection ou cliquez en maintenant la touche Maj. enfoncée pour ajouter plus d'objets.
  4. Quand vous avez fait une sélection complète, cliquez droit et choisissez Prendre dans le menu contextuel.
  5. Attendez quelques instants, un peu plus si vous avez sélectionné des milliers de prims, et vos objets devraient tous disparaître.
  6. Les premières fois, au moins, ouvrez le dossier Objets de votre inventaire pour confirmer que les objets sont bien arrivés. Si vous avez pris plusieurs objets en même temps, le nom du dernier objet sélectionné apparaît ici.
    • Vous êtes peut-être curieux de rezzer les objets et de voir ce qu'il y a dedans, mais à moins que les objets ne soient tous copiables — et n'aient pas de mention "(no copy)" — ne le faîtes pas. Ayez conscience des permissions, car la perte d'un objet non copiable sans sauvegarde est définitive.

Migrer les paramètres de la fenêtre À propos du terrain

Après avoir enregistré les paramètres de la parcelle :

  1. Téléportez-vous vers la parcelle où vous allez emménager.
  2. Si les paramètres enregistrés de votre parcelle ne sont pas visibles, ouvrez-les.
  3. Utilisez le menu Monde > À propos du terrain pour ouvrir ou rafraîchir ces nouveaux paramètres pour la parcelle.
  4. Commencez par remplacer les paramètres précédents, soit en tapant les mêmes valeurs soit en faisant des copier/coller.

Rezzez vos objets sur la parcelle de destination

Avant de rezzer, vérifiez les performances de la région. Essayez aussi de faire ce test quand il y a peu ou pas d'avatars dans la région, car ils ajoutent de la charge et augmentent les chances d'erreur. Par exemple, si vous essayez de déplacer un ensemble d'objets de 1.000 prims quand la dilatation temporelle est mauvaise, les prims bougent de manière erratique et certains peuvent être oubliés derrière dans la confusion. Il vaut mieux éviter cette situation gênante.

Activez le tag de votre groupe

Cela ne s'applique que si la parcelle de départ était dédiée à un groupe et cette manipulation est importante pour s'assurer que les objets restent au lieu d'être renvoyés automatiquement dans votre inventaire.

Dans l'onglet Général du À propos du terrain, assurez-vous que le propriétaire et le groupe sont bien configurés. Autrement vous augmentez le risque de perdre des objets.

Si c'est le cas, assurez-vous que votre propre tag de groupe est configuré correctement pour correspondre à la configuration de la parcelle :

  1. Cliquez sur Communiquer dans la barre d'outils.
  2. Cliquez sur l'onglet Groupes.
  3. Cliquez sur le bon groupe.
  4. Cliquez sur le bouton Activer (sur la droite). Si les tags de groupes sont visibles, vous le verrez au-dessus de votre tête.

Chaque objet que vous rezzez pendant que vous portez ce tag est automatiquement dédié à ce groupe. (Vous pouvez affecter des groupes plus tard, mais les étapes précédentes vous évitent d'oublier de le faire.)

Positionnez-vous et rezzez

  1. Déplacez votre avatar vers le centre de la parcelle de destination et envolez-vous pour avoir suffisamment de recul pour pouvoir voir toute votre construction pendant que vous la rezzez sans avoir à bouger continuellement.
    • Si votre parcelle est très grande (d'une surface supérieure à 8.192 m2, par exemple) ou s'étend haut dans le ciel, vous devrez peut-être voler autour et vous repositionner de temps en temps.
  2. Éventuellement, placez votre caméra en vue aérienne. Ou vous préférerez peut-être voir votre construction de manière isométrique. Tout ce qui vous donne la meilleure perspective sur votre construction.
  3. Passez en mode Édition.
    • Ce point est "vraiment" important car si vous rezzez des objets sans être en mode Édition, vous aurez beaucoup de mal à les repositionner !

Répétez chaque étape pour chaque objet ou agglomérat d'objets :

  1. Rezzez un objet pour lequel vous avez une bonne idée de l'endroit où il doit aller.
  2. Attendez quelques instants jusqu'à ce que le champs "Objets sélectionnés" se stabilise dans la fenêtre d'Outils. Cela peut durer plus longtemps avec un grand nombre de prims ou dans une région où les performances sont médiocres.
  3. Déplacez l'objet en utilisant les flèches de positionnement.
  4. Lorsque vous êtes satisfait, et seulement à ce moment là, cliquez ailleurs pour déselectionner l'objet ou rezzer un autre objet.

Ce qui est mentionné ci-dessus ne s'applique pas aux systèmes de rezz d'objets qui sont beaucoup plus tolérants en cas de mauvais placement d'un objet.

Répétez l'opération jusqu'à ce que vous ayez fini. Vous voudrez peut-être faire des réglages plus précis et le déplacement de votre construction fera peut-être apparaître des faiblesses dans l'original que vous voudrez peut-être corriger — vous avez là une bonne occasion pour cela !

Inspectez tout

Une fois que la structure de votre construction est en place :

  1. Survolez-là et vérifiez tout sous des angles différents. Affinez vos réglages si nécessaire.
  2. Terraformez le terrain pour qu'il s'adapte mieux à votre construction.
  3. Cliquez sur tous les objets scriptés pour vous assurer qu'ils fonctionnent comme prévu. (si vous avez l'habitude des scripts, profitez de cette occasion pour les recompiler pour Mono.)
  4. Invitez vos amis et faîtes la fête !

Félicitations ! Vous êtes arrivé au bout de votre déménagement ! Bonne seconde vie !