Selection Test

From Second Life Wiki
Jump to: navigation, search

todo: merge Selection_test with this test.

[SelectionTestScript]

[VERSION] 0.1

[LENGTH] 00:60

[TESTERS] 1

[OVERVIEW] This test has been designed to test the various ways of Selecting.

[SETUP] 1 user, Rezzable land, Parcels of Public Land

[*]

Log in. Right-click an object which is already in-world.

Verify the pie menu pops up.

Verify you see the selection outline around the object.

Left-click elsewhere on the screen

Verify the pie menu closes, and the item deselects.

Right-click on object which is already in-world, Select Edit.

Verify the Edit menu opens.

[*]

Right-click on the ground, then select CREATE and rez a default cube

Right-click on the Cube, then select Edit.

In the Edit Window, Click the "more >>" button if not already open.

In the Edit Window, select the General Tab.

Tick the "For Sale" Checkbox

Enter a price of $4 in the "Price:" Window

Deselect and Then Reselect the For Sale Checkbox

Verify the Price is Correct

Close the Edit window

Right-click on the Cube, then select Edit again.

Verify the Price is still Correct

[*]

Right-click on the ground, then select CREATE and rez a default sphere not touching any other objects

Close the Edit window

Left-click the sphere, and verify you cannot select it or drag it.

Right-click on the Sphere, then select Edit.

In the Edit Window, select the Object Tab.

Tick the "Physics" Checkbox

Close the Edit window

Verify your cursor changes to a hand when you hover it over the sphere.

Left-click and hold click over the sphere, Drag the sphere around.

Verify your hand cursor dissapears, but you have a selection line running from your hand to the object.

Verify the sphere does not have a selection outline.

[*]

Right-click on the ground, then select CREATE and rez a selection of different prims.

Right-click on one, then select Edit.

Go through the various tools, Position, Rotate, Stretch, Move on each of your prims

Find an few Objects belonging to someone else

Right-click on one, then select Edit.

Go through the various tools, Position, Rotate, Stretch, Move on each of your prims

Verify you see appropriate object modify arrows or handles Only on objects that you have permission to move, resize, or rotate.

[*]

Right-click on the ground, then select CREATE and rez 3 default cubes

Right-click on one, then select Edit.

While leaving the edit window open Hold Down the Shift Key and Left-click on the other two prims

Verify you see all three with the selection outline

Link them together by Chossing The Tools menu > Link or Ctrl L

Verify two of the selection outlines have turned blue (these are the child prims) and the last object you selected is still yellow (this is the parent prim)

Select the "Edit Linked Parts" Tickbox in the edit tools

Left-click on one of the cubes (selecting it)

Verify that only the Prim you Clicked on now has the Selection outline

Deselect the "Edit Linked Parts" Tickbox in the edit tools

Verify The selection outline now includes the other objects of the linked set

Click the "Stretch" Radio Option in the edit tools

Verify you only see the white/grey pull tags in each corner of the linked set

Left-click and hold one of the pull tags and drag it outwards making the linked set larger

Close the Edit window.

Verify the linked set does not snap back to it's original scale

[*]

Right-click on the linked set, then select Edit.

Click "Select Texture" in the edit tools.

Verify all sides have a circle crosshair on them.

Select one side of one of the cubes.

Verify only that side now has the circle crosshair, and that prim is the only one with a white selection outline.

Select "Position" in the edit tools.

Verify The selection outline now includes the other objects of the linked set

Click the "Stretch" Radio Option in the edit tools

Verify you only see the white/grey pull tags in each corner of the linked set

Left-click and hold one of the pull tags and drag it closer making the linked set smaller

Close the Edit window.

Verify the linked set does not snap back to it's original scale

Clean up your created prims

[*]

Move to a corner of 4 sims

Select something on an adjacent sim, if nothing available then create an object

Verify it works and appears correct.

Select something on an catercorner sim (not adjacent but diagonal), if nothing available then create an object

Verify it works and appears correct.

Clean up your created prims if necessary

[*]

[Group Selecting]

[*]

"Group Select" means "Drag a selection square around objects while in edit mode".

[*]

Right-click on the ground, then select CREATE and rez 4 default spheres

In the Edit Window, select the Object Tab, and set Material to "Light"

Group Select the 4 Prims, by Dragging a Square Selection around them

Click the Tools Menu > Select Only My Objects

Verify in the Tools Menu that this option is now Selected

Verify only these 4 Spheres now have the Selection outline

Change the Position of the selected objects

Verify they all move as expected.

Shift and Left-click on some of the Spheres to remove them from the Selection

Change the Position of the selected objects

Verify the selected objects moved and the objects you just deseleced didnt move.

Shift and Left-click on some of the Spheres you removed from the Selection to add them back in.

Verify the selected objects moved and the objects that are deseleced didnt move.

Deselect the Tools Menu > "Select Only My Objects"

Verify in the Tools Menu that this option is now De-selected

Group select some of your own objects along with someone else's.

Verify that although yours and the other persons objects are selection outlined, no positioning options are presented, therefore you cant move either yours or their objects.

Close the Edit Window and Clean up your Prims.

[*]

Right-click on the ground, then select CREATE and rez 3 default cubes

Right-click on one, then select Edit.

While leaving the edit window open Hold Down the Shift Key and Left-click on the other two prims

Verify you see all three with the selection outline

Link them together by Chossing The Tools menu > Link or Ctrl L

In the Edit Window, select the General Tab.

Tick the "For Sale" Checkbox

Enter a price of $25 in the "Price:" Window

Close the Edit Window

Right-click on the linked object, then select Edit.

Group select your own linked object.

Verify the creator/owner/cost of the object is correct.

In Position Mode, Hold Down the Shift Key and Drag at one of the direction arrows to pull a copy of the linked prim out of the original, do this another time so you have two copies and the original.

Right-click on the ground, then select CREATE and rez a default cube

Right-click on one of the objects, then select Edit.

Group select all the objects.

Verify the creator/owner/price of the objects is correct.

[*]

For sale, Will still be ticked even though only one object is Forsale, Although greyed out the Price: Box Will Show the price of any selected items For Sale, but you cant change it.

[*]

Close the Edit Window and Clean up your Prims.

[*]

Right-click on the ground, then select CREATE

Verify you can click on the pie menu succesfully and it opens the edit window

Rez a default cube

Then by copying and linking and recopying, Attempt to group select more than 256 objects and link them together into one object.

Verify you get a message similar to this, "Unable to link these 257 objects, You can link a maximum of 256 objects. Try selecting fewer objects."

Delete the required objects to take you to the 256 object limit.

Verify the object links properly, and that you can move it around without any prims being left behind.

Clear up your Workspace.

[*]

Activate your "none" Group from the Edit > Groups Menu

Choose some land which is owner by someone else.

Right-click on the land and Select "About Land..."

Verify in the General Tab the "Buy Land..." and "Release Land..." buttons do NOT appear clickable.

Close the About Land Window

Activate a Group other than "none" from the Edit > Groups Menu

Choose some land which is owner by someone else.

Right-click on the land and Select "About Land..."

Verify in the General Tab the "Buy Land...", "Buy For Group..." and "Release Land..." buttons do NOT appear clickable.

Close the About Land Window

[*]

[SubObjects In A Linked Set]

[*]

Right-click on the ground, then select CREATE and rez a sphere a cube and a cylinder

Right-click on one, then select Edit.

While leaving the edit window open Hold Down the Shift Key and Left-click on the other two prims

Verify you see all three with the selection outline

Link them together by Chossing The Tools menu > Link or Ctrl L

Verify two of the selection outlines have turned blue (these are the child prims) and the last object you selected is still yellow (this is the parent prim)

Select the "Edit Linked Parts" Tickbox in the edit tools

Left-click on one of the child prims (outlined in blue) ,selecting it

Verify that only the Prim you Clicked on now has the Selection outline

Click the Object Tab in the Edit Window

Verify you can see the Shape Properies of the child object you clicked and is highlighted

Click the Stretch Radio Button

Click and use the red/green/blue tabs on the child prim to alter the size

Click and use the white corner tabs to scale the size of this prim

Use the Numerical or Arrow toggles in the Objects Tab of Edit under Size(meters) to further change the size of the child prim.

Verify you can change the size of the child object using the above methods and there was no snap back

Next Click the Tools Menu > Unlink or Ctrl-Shift-L?

Close the edit window

Right-click on the prim you changed the size of, then select Edit.

Using the position arrows drag it around slightly

Verify it is the only prim to move and is the only one highlighted, and it has also retained the shape/size you altered it to.

Close the edit Window, and Clean up your prims

[*]

[Select Land]

[*]

Find an Area of Land for Sale.

Right-click on the ground, Select Edit Land.

Verify a yellow fence appears around the parcel.

while Still in Edit Land, Drag-select the ground to select a larger parcel of land.

Click the "Buy Land..." Button

Close the Edit Land Window.

Right-click your parcel and choose "About Land" from the pie menu.

Verify the land is selected and you can modify it's properties in the About Land Window.

Close the About Land Window

Release the land. Delete any of your objects from the ground.

[*]

[Selection of Text from Chat Bar]

[*]

Type some text into the Chat Bar but dont press Enter or The "Say" Button

Left-click and Hold Click and Drag the mouse over some of the text or Press Ctrl-A to select it All.

Verify the Text you Selected Becomes Highlighted

Click the Edit Menu and Copy or Ctrl-C

Chat the text you typed, even highlighted it should appear normally.

In the Empty Chat Window, Click The Edit Menu and Paste or Ctrl-V and chat it

Verify that the text chatted matches the text you highlighted and copied.

[*]

[Selecting Text in Scripts and Notecards]

[*]

Open your Inventory, From the Create Menu at the Top, Click New Script

Double click on the Highlighted Script called "New Script" to open it

Using you mouse, Left click and Select the Text, llSay(0, "Hello, Avatar!");

Click the Edit Menu and Copy or Ctrl-C

Click the Mouse at the end of the line after ";"

Click The Edit Menu and Paste or Ctrl-V

Verify the line looks like the following, llSay(0, "Hello, Avatar!");llSay(0, "Hello, Avatar!");

Save the Script

Click The Edit Menu and Select All or Ctrl-A

Click the Edit Menu and Copy or Ctrl-C

In your Inventory Window, From the Create Menu at the Top, Click New Note

Double click on the Highlighted Note called "New Note" to open it

Left Click inside the Note, so you see the cursor Flashing

Click The Edit Menu and Paste or Ctrl-V

Verify All the Script you Selected and Copied has now being Pasted to the Notecard.

Left click and hold and Drag the mouse over some of the text Selecting and Highlighting it.

Click the Edit Menu and Copy or Ctrl-C

Click the mouse at the bottom and Click The Edit Menu and Paste or Ctrl-V

Verify only part of the text you just Selected and Copied was Pasted.

Close and Save Both Note and Script.

[*]

[Selecting Items in Inventory]

[*]

Find a folder in your Inventory with a few Items

Left-Click? on one Item then Shift-Left-Click? on another items 4 or 5 items down the list

Verify all the items become selected including the ones clicked

Right-Click? on any of the selected items and select copy

Select a different folder, Right click on it and Select Paste

Verify Either Copys or The Originals (If the item was no copy) has been placed in this new location

Go back to were originally, Left click on one item and this time Ctrl-Left-Click? on an item 2 or 3 down, then Ctrl-Left-Click? again leaving another gap of 2 or 3 items.

Verify only the items clicked become selected and NOT the ones skipped.

Right-Click? on any of the selected items and select copy

Select a different folder, Right click on it and Select Paste

Verify Either Copys or The Originals (If the item was no copy) has been placed in this new location

[*]

[Selecting Objects Contents]

[*]

Right-click on the ground, then select CREATE and rez a cube

Right-click on one, then select Edit.

Click the Content tab

From your Inventory Drag 3-5 items to Contents Folder of the Cube

In the Cubes Contents Left-click on the top item and Shift-Left-Click? on the bottom item

Verify all items become Selected and Highlighted including those clicked.

In the Cubes Contents Left-click on the top item and Ctrl-Left-Click? on the bottom item

Verify only the items clicked have become Selected and higlighted and those skipped have NOT.

If needed copy the items back to your inventory, Then Delete the Cube

[*]

Although you can right click and Select Copy on Multiple Selected Items in Contents at this point you cant Paste it to your Inventory or another Object. The Same goes the other way, you cant Multi Select Copy from your inventory to a Prim (You still can Drag a Folder which will move its contents)

[*]

[Map Item Selection]

[*]

Open the Map

Toggle the, "Classifieds" , "Person", "Infohub", "Telehub", "Events", "Events (M)", "Popular" and "Land For Sale" tickboxes

Verify if available you see changes in the map for each Button Toggled.

If a friend is online Verify you can Select them from the Drop down Menu

Verify that the Map Beacon has Moved to their Position, using the zoom in/out and scroll or clicking Show Destination if necessary.

Enter the first three letter of a Simname into the Find Region box and press Enter

Verify that the Map Beacon has Moved to the centre of that Sim, By Scrolling or clicking Show Destination

While the Sim is Still Selected, Alter the co-ordinates from 128,128

Verify that the Map Beacon has Moved to the new position in that Sim

Select a Landmark from the Landmarks List, Making a quick note of the sim/location

Verify that the Map Beacon has Moved to the Location in the Landmark, By scrolling or clicking Show Destination

Close the Map

[*]

[Selecting Text in IM or Chat History (While Someone Else Is Chatting)

[*]

Search for someone online, In a busy area or using Find People / Map

Open your Inventory Window, From the Create Menu at the Top, Click New Note

Double click on the Highlighted Note called "New Note" to open it

Start up an IM conversation

In the IM Chat History Window, Left-Click? and Drag to Select Some Text

[*]

The Selected Text Will Remain Highlighed Until you recieve another message or you type.

[*]

Click the Edit Menu and Copy or Ctrl-C

Click into the Notecard

Click The Edit Menu and Paste or Ctrl-V

Verify the Text pasted into the notecard is that what you selected in the IM History Window.

Click back into the IM History Window

Click The Edit Menu and Select All or Ctrl-A

Click the Edit Menu and Copy or Ctrl-C

Click into the Notecard

Click The Edit Menu and Paste or Ctrl-V

Verify the Text pasted into the notecard is all the selected text in the IM History Window.

[*]

Open the Chat History Window

Left-Click? and Drag to Select Some Text

[*]

The Selected Text Will Remain Highlighed Until you recieve another message or you type.

[*]

Click the Edit Menu and Copy or Ctrl-C

Click into the Notecard

Click The Edit Menu and Paste or Ctrl-V

Verify the Text pasted into the notecard is that what you selected in the Chat History Window.

Click back into the IM History Window

Click The Edit Menu and Select All or Ctrl-A

Click the Edit Menu and Copy or Ctrl-C

Click into the Notecard

Click The Edit Menu and Paste or Ctrl-V

Verify the Text pasted into the notecard is all the selected text in the Chat History Window.

Close the Notecard and Clean up any Prims.