Viewer menu

From Second Life Wiki
Jump to: navigation, search
KBcaution.png Important: This is an unofficial guide for Second Life Viewer 1.23 helpfully compiled by Second Life Residents. Much of it does not apply to the current version of the SL Viewer (Viewer 2).

This page is part of the Second Life User's Manual, describing how the Viewer software works. Please see the main User's Manual page as a starting point.

Most functions within the Second Life (SL) viewer are performed using menus and floating windows. This page describes the functions that appear in the 6 top left drop-down menus as of viewer version 1.23. Two other drop-down menus (Advanced and Admin) are off by default and have their own page. There are also Context Menu, and Inventory Menu descriptions on their own pages. For windows, please see the Floating Windows summary page.

Top Left Corner of Viewer Screen

The Top Menu Bar is part of the User Interface which always appears on your screen or window when the program is running. Dropdown menus appear on the left side of the bar. A reduced version is available before logging in, and the first six menu headings appear after login. The last two headings (Advanced and Admin) do not appear by default, but can be turned on optionally.

The menus are organized and operate similar to most modern software with menus. Click the heading to see the dropdown menu. Moving the mouse over the items will highlight the items. Sliding the mouse right to the submenu will highlight those items. Click the mouse over the desired item to activate that item. Items not available are greyed out.

The menus use a number of conventions to indicate the characteristics of each entry, as follows:

  • Entry preceded by "X": the entry is activated (such entries are toggles - click a second time to deactivate them)
  • Entry followed by ">": clicking on the entry will open a secondary menu
  • Entry followed by "...": clicking on the entry will open a floating window
  • A character or group of characters to the right of the entry: keyboard shortcut for that command

File Menu

V1.23 File Menu.jpg

The File menu contains items for uploading, saving, and downloading files, and quitting the Viewer program.

  • Upload > - A fee of L$10 is charged for each item uploaded.

> Image - Opens a browser window to upload an image file from your computer to your SL Inventory. Image files are forced to power-of-2 dimensions (ie 128, 256, 512, etc) for efficient storage in graphics card memory. The maximum size is 1024x1024 pixels. Image files which are not already one of the correct sizes will be adjusted to the nearest one, distorting the image. Source images may be BMP, JPG, PNG or TGA files with at least 24-bit color. TGA files may also be saved as 32- bit files, which allows the use of an alpha channel (a form of transparency). You may not upload files saved in 8-bit, 16-bit or palletized color.

> Sound - Opens a browser window to upload a sound file. Select a .WAV file to upload. Valid files are any .WAV file in standard PCM format, 16-bit/44.1kHz/mono or stereo (which will be converted to mono), less than 10 seconds in length. Sounds cannot be formatted as MP3s or .WAVs in 8-bit, 22.05 kHz, or any other frequency.

> Animation - Opens a browser window to upload an animation file. # Choose a valid .BVH animation file to upload; valid files are usable in Poser 2 or newer, at a recommended setting of 10 frames per second. Select your desired settings from the Animation Upload window and press Upload.

> Bulk - Opens a browser window to upload multiple files at one time. In the Open dialog, select all the files you wish to upload. Using this method, you can upload files of different valid formats at the same time.

> Set Default Permissions - Opens default permissions floating window.

  • Close Window - Closes the currently focussed floating window
  • Close All Windows - Closes all floating windows within the viewer.
  • Save Texture As - Saves a texture file from your SL inventory to your computer if you have copy permission on the texture.
  • Take Snapshot - Opens "Snapshot Preview" floating window.
  • Snapshot to Disk - Saves the current 3D view image frame generated by your graphics card or chip to your computer hard drive in uncompressed png format. The dimensions of the image will match the dimensions of the screen or window.
  • Quit - Exits the Viewer program. While there is a login page when starting the program, there is no separate logout function. Exiting the Viewer (or otherwise losing your connection to the Second Life server) will cause the server to log you out automatically.


Edit Menu

V1.23 Edit Menu.jpg
  • Undo - If an item has an edit history, undo backs up one step in the history. Undo works only for text editing within notecards and scripts, sliders within editing appearances, and object move, scale and rotation operations. Closing then opening or taking and rezzing an object clears the object's undo history.
  • Redo - If an item is not at the end of it's edit history, goes forward one step in the history. Applies to same classes of items as undo.
  • Cut - Copies selected text field to clipboard and removes it from view. (TBD - do edit commands work on other things than text fields?)
  • Copy - Copies selected text field to clipboard and leaves original in place.
  • Paste - Copies current clipboard to cursor location.
  • Search - Opens "Search Second Life" floating window
  • Select All - In text field, selects all text
  • Deselect - In text field, deselects all text
  • Duplicate - In edit mode, creates a copy of a copiable object 0.5m NE of the original object
  • Attach Object > - Takes a rezzed object in edit mode and attaches it to selected location from submenu. This also places it in inventory.
  • Detach Object > - Detaches selected submenu item from avatar attachment point. Attach points with no attached objects are greyed out.
  • Take Off Clothing > Removes selected submenu clothing item from avatar. Items not currently worn are greyed out.
  • Gestures - Opens "Active Gestures" floating window
  • Profile - Opens your avatar's "Profile" floating window. Profiles are generally visible to other avatars.
  • Appearance - Opens "Appearance" floating window, and enters appearance mode to edit your avatar's appearance.
  • Friends - Opens "Contacts" or "Communicate" floating window to 'Friends' tab, depending on whether the contacts window has been torn off the communicate window.
  • Groups - Opens "Contacts" or "Communicate" floating window to 'Groups' tab, depending on whether the contacts window has been torn off the communicate window.
  • Preferences - Opens Preferences floating window. This window is used to set many settings within the Viewer program. It is accessible before logging in, although a few settings require being logged in to set.


View Menu

V1.23 View Menu.jpg
  • Mouselook - Enters mouselook mode. This places the camera view at your avatar's head, instead of wherever it was before.
  • Build - Opens "Create" tool floating window, and changes cursor to magic wand. Clicking shape in window, then someplace in the 3D view area will create an object of that type.
  • Joystick Flycam - If joystick is connected to your computer, enables functions like camera control with it.
  • Reset View - Returns camera view to "default" location, which is behind and above your avatar.
  • Look at Last Chatter - TBD
  • Toolbar - Toggles lower toolbar buttons from screen view.
  • Local Chat - Toggles "Local Chat" history floating window
  • Communicate - Toggles "Communicate" floating window
  • Inventory - Toggles "Inventory" floating window
  • Active Speakers - Toggles "Active Speakers" floating window, which lists voice chat users in range.
  • Mute List - Toggles "Muted Residents & Objects" floating window
  • Camera Controls - Toggles camera control panel floating window
  • Movement Controls - Toggles movement control panel floating window
  • World Map - Toggles "World Map" floating window
  • Minimap -Toggles minimap floating window
  • Statistics Bar - Toggles "Statistics" floating window
  • Property Lines - Toggles visibility of parcel and region property boundaries in the 3D view area. Parcel colors: green = your land, blue = your group's land, red = someone else's land, orange = land for sale, purple = auction land. Region boundaries have double lines. Boundaries have tick marks every 4 meters, which corresponds to the smallest land unit (4x4 meters).
  • Banlines - Toggles visibility of parcel ban lines, which appear when you are close to land you cannot enter.
  • Land Owners - Toggles color overlay on land parcels using same colors as property lines.
  • Hover Tips > - When mouse pointer is held over an object for several seconds, a small box will appear. It shows the name of the object, owner, and a few other bits of information depending on the object's edit settings.

> Show Tips - Toggles visibility of hover tips for scripted objects.

> Land Tips - Toggles visiblity of hover tips for land parcels. Shows parcel name, owner, and a few bits of other information.

> Tips On All Objects - Adds visibility of hover tips for all objects, not just scripted ones.

  • Highlight Transparent - Toggles visibility of red highlights for objects with partial or full transparency (alpha channel in the object texture). This is helpful in finding 'invisible' objects.
  • Beacons - Toggles "Beacons" floating window
  • Hide Particles - Toggles rendering of particles on 3D view. Particles are temporary items emitted by a more permanent object.
  • Show HUD Attachments - Toggles visibility of Head Up Display items attached to 3D view plane.
  • Zoom In - Expands 3D view scale without moving camera viewpoint
  • Zoom Default - Returns to normal view scale
  • Zoom Out - Contracts 3D view scale without moving camera viewpoint
  • Toggle Fullscreen - Toggles Viewer running in fullscreen vs windowed mode
  • Set UI Size to Default - Sets User Interface (text) size to 1.000


World Menu

V1.23 World Menu.jpg
  • Chat - Toggles bottom toolbar chat bar.
  • Always Run - If not overriden by an animation override device, will make avatar run instead of walk.
  • Fly - Toggles fly mode. Does not work on parcels where flying is not allowed.
  • Create Landmark Here - When 'create landmark' option is active for a parcel, adds a landmark for the parcel you are located at to your inventory
  • Set Home to Here - If you own a land parcel, or have group membership that permits setting home location, will set your home location to your current location.
  • Teleport Home - If home location is available, teleports you to that location. By default, home is the first infohub you land at after orientation. Your home location may not be available if the region is 'full' (has reached the maximum number of avatars allowed), or is not being simulated by a server (which would be a technical problem), or no longer exists (if a region has been removed from the grid).
  • Set Away - Sets away status. Also known as AFK (away from keyboard). If you do nothing while logged in, this happens automatically after 5 minutes, or if you change windows to another program than Second Life. Any action in the Second Life window will remove away status. When away, your avatar name bubble will show "(Away)" after your name, and the avatar will appear to be asleep.
  • Set Busy/Set Not Busy - Note: Menu Item will change according to your busy status. When in busy status, instant messages are answered by your busy text message (in Edit Menu > Preferences > Communication Tab), item transfers are declined, and your avatar name bubble will show "(Busy)" after your name.
  • Stop Animating My Avatar - Misnamed, this item attempts to stop any animations other than the default one from running. Your avatar is *always* using an animation, but by default the built in ones are used for standing, sitting, walking, etc.
  • Release Keys - Removes special key assignments set by a scripted object
  • Account History - Opens Account History web page. Your account history tracks up to 30 days of item and money transfers.
  • Manage My Account - Opens Account Summary web page. The summary page shows your subscription and payment plan, money balances, and land ownership. It also has links to other account details and functions.
  • Buy L$ - Opens 'Buy Currency' floating window. If you have provided payment information (a credit card or PayPal), allows you to buy Linden Dollars (L$) in exchange for US$ at the market exchange rate (approx 270L$/US$). A fee of US$0.40 is added for purchases. Minimum charge is US$2.50 (approx 570L$). If you are unable to use this, you may use alternate currency exchanges, or make a private arrangement to buy L$ from another user, or earn L$ in-world.
  • My Land - Opens 'My Land' floating window, which shows your own land holdings, contributions of area to group owned land, current totals and available unused area.
  • About Land - Opens 'About Land' floating window, which gives detailed information about the land parcel at your current location. You can get information about nearby parcels via the Land context menu.
  • Buy Land - If land is set for sale to you, or to anyone, opens 'Buy Land' floating window.
  • Region/Estate - Opens 'Region/Estate' floating window. This window allows setting region-wide, or estate (multi region land holdings under one owner) wide settings. You must own a full region or more to access the settings.
  • Environment Settings > - Accesses settings for apparent time of day, sky and water. These only affect what you see on your own computer. Note that sun position affects interior lighting even in buildings with a roof and no windows.

> Sunrise - Sets apparent time of day to sunrise.

> Midday - Sets apparent time of day to midday.

> Sunset - Sets apparent time of day to sunset.

> Midnight - Sets apparent time of day to midnight.

> Revert to Region Default - Sets apparent time to that of the current region.

> Environment Editor - Opens 'Environment Editor' floating window, which allows more detailed control of the sun, sky, and water appearance.

Tools Menu

V1.23 Tools Menu.jpg
  • Select Tool > Opens submenu for one of the tools floating window pages.

> Focus - Tool to zoom (scroll wheel), orbit (Ctrl + click-drag), and pan (Ctrl + Shift + click-drag). the camera view

> Move - Tool to move an object horizontally and vertically while keeping the view centered on it. Rotate appears not to work.

> Edit - Tool for detailed editing of an object.

> Create - Tool for creation of a fresh object in the 3D view.

> Land - Tool for changing the vertical shape and boundaries of a land parcel.

  • Select Only My Objects - When editing objects, limits selection via click-drag to objects you own
  • Select Only Movable Objects - When editing objects, limits selection vis click-drag to objects that are not locked.
  • Select By Surrounding - When one item is already in edit mode, lets you add to the selection by click-drag, which will show a yellow highlight area and select all the objects in that area, modified by the above two menu choices.
  • Show Hidden Selection
  • Show Light Radius for Selection - When the selected item(s) are emitting light, this option will mark the light radius with a sphere.
  • Show Selection Beam - Shows / hides a particle beam that appears when an item is selected.
  • Snap to Grid - When editing an object and dragging it in the 3D view, a ruler can appear on either side of the colored axis line. Sliding the mouse pointer to one of the rulers will make the object jump in increments of the ruler than move smoothly.
  • Snap Object XY to Grid - This option will make the selected object jump to the next nearest point in the xy grid.
  • Use Selection for Grid - This will center the ruler relative to the selected object. Other objects can therefor more easily be adjusted relative to the first object.
  • Grid Options - Opens a floating window which allows you to specify grid options. (units, extents, etc.)
  • Edit Linked Parts - Allows editing a single part of a complex object.
  • Link - Objects are made from one of more primitive shapes (prims), such as cubes, cylinders, or pyramids. This function connects the selected items together to make one complex object. There are limits to link distance.
  • Unlink - Separates the selected item into simple prim shapes.
  • Focus on Selection - Your camera focuses on the selected item.
  • Zoom to Selection - Your camera focuses and zooms into the selected item.
  • Take - Removes the selected item or items from the 3D grid and places it in your personal inventory
  • Take Copy - Places a copy of the selected item in your personal inventory
  • Save Object Back to Object Contents - When an object is rezzed from another objects contents, this option should put it back in there. Though it seems to be buggy.
  • Show Script Warning/Error Window - Opens a floating window which shows the latest error messages, caused by LSL scripts.
  • Recompile Scripts in Selection >

> Mono - Compiles all scripts within the objects contents, using the mono compiler.

> LSL - Compiles all scripts within the objects contents, using the old LSL compiler.

  • Reset Scripts in Selection - Resets all scripts in the object. All global variables will have their default values again and the script will trigger a state_entry event in the default state.
  • Set Scripts to Running in Selection - All scripts in the object will be set to running and therefor react on events.
  • Set Scripts to Not Running in Selection - All scripts will be set to not running (paused, not detecting any events).


Help Menu

V1.23 Help Menu.jpg
  • Second Life Help - opens a Knowledge Base web browser page with links to many basic questions.
  • Tutorial - Opens a very basic tutorial floating window
  • Official Linden Blog - Opens a web browser page to the official Second Life Blogs
  • Scripting Portal - Opens a web browser page to the LSL Portal Wiki. LSL is the Linden Scripting Language, which is used to write software scripts installed in objects within Second Life to make them do things. Unscripted objects are static - they can be seen in the 3D view, but do not move or perform any actions.
  • Report Abuse - Opens the 'Report Abuse' floating window. This window is used to report other users or objects which violate Second Life's rules. These reports are investigated by Linden Lab staff and action is taken by them if needed.
  • Bumps, Pushes & Hits - Opens the 'Bumps, Pushes & Hits' floating window, which records any you have recieved.
  • Lag Meter - Opens the 'Lag Meter' floating window. "Lag" is any perceived delay between an action you take, and seeing the response on the screen. Second Life involves your computer, running the Viewer client software, the Linden Lab server you are connected to when logged in, and the Internet in between. Any or all of these can cause slowness, and this simple window attempts to give an indication of which may be the source. More details can be seen using the Statistics Bar.
  • Bug Reporting >

> Public Issue Tracker - Opens a web browser link to the Second Life Issue website. This is a technical site for users to submit or add to issues they have with Second Life's software. These are then looked at by Linden staff for fixing.

> Public Issue Tracker Help - Opens a web browser to the Issue Tracker wiki information page.

> Bug Reporting 101 - Opens a web browser to the Bug Reporting 101 wiki page.

> Security Issues - Opens a web browser to the Security issues wiki page.

> QA Wiki - Opens a web browser to the QA Portal wiki page. QA, or Quality Assurance, is the testing of software before it is released officially to make sure it works properly.

> Report Bug - Same as Public Issue Tracker item above

  • About Second Life - Opens the 'About Second Life' floating window, which lists the version you are running, your location and server connection, and your computer specifications.


Advanced And Admin Menus

V1.23 Advanced Menu.jpg
V1.23 Admin Menu.jpg

These menus have advanced user or Linden Staff functions, and are turned off by default. See Advanced menu for details.


Context Menus

V1.23 Context Object 1.jpg

If you click the right mouse button (RMB) (PC)or CMD-click (MAC) in the 3D view area, a context menu will appear. This menu is round and is often called the "pie" menu because of how it looks. The menu will change according to what you are pointing at (object, your avatar, another avatar, land). For details, see the Context Menu page.

Inventory Menus

V1.23 Inventory Notecard Context Menu.jpg

The Inventory floating window has both dropdown menus, and context menus. For details, see Inventory Menu

See Also