Talk:Open Source Holodeck

From Second Life Wiki
Revision as of 03:08, 10 October 2011 by Len Lectar (talk | contribs) (→‎Corrected poor function names: new section)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to navigation Jump to search

It is not a good idea to use the "ll" prefix in your own code, such as llPrototypeSay and llDebugSay because "ll" prefix is reserved for Linden Lab, and in case if some time in the future LL decides to use these same names, then you will have a name collision, and your code would break when it is overridden by the LL functions. Nicoladie Gymnast

Privacy Concern

I note that a holodeck containing this script (in particular, Holodeck Core) will apparently send an email to whenever the holodeck itself is rezzed. The emal will contain the region and coordinates of the holodeck, the holodeck owner's name, and the holodeck owner's avatar key. If this is a privacy concern, I suggest commenting out the appropriate lines in the on_rez event of the default state of the Holodeck Core script. -- Len Lectar 00:37, 7 October 2010 (UTC)

Corrected poor function names

Implemented the suggestion by Nicoladie Gymnast, who commented that "It is not a good idea to use the "ll" prefix in your own code,". Renamed the functions: llPrototypeSay to PrototypeSay, and llDebugSay to DebugSay, checking first that no name conflicts would be introduced. Also deleted llPrototypeSay from "internal label script" because it was not used. Len Lectar 04:08, 10 October 2011 (PDT)