Difference between revisions of "Certified HTTP Python"

From Second Life Wiki
Jump to: navigation, search
(Getting Started)
(uuid.py link)
Line 13: Line 13:
 
  export PYTHONPATH=`pwd`
 
  export PYTHONPATH=`pwd`
  
* If you're running Python 2.3, you will need a deque object and <code>uuid.py</code> from, uh, Python 2.4 or later:
+
* If you're running Python 2.3, you will need uuid.py from the 2.4 distribution (you can snag a copy [http://zesty.ca/python/uuid.py here]).
  cp /usr/lib/python2.4/uuid.py ./
+
(note: no idea how to get a deque object implementation, just use 2.4)
+
  
 
We know we should get auto-dependencies figured out, but haven't gotten around to it.  We'd be happy to accept contributions that speed that process along. [http://jira.secondlife.com/browse/CHTTP-13]
 
We know we should get auto-dependencies figured out, but haven't gotten around to it.  We'd be happy to accept contributions that speed that process along. [http://jira.secondlife.com/browse/CHTTP-13]

Revision as of 18:11, 10 November 2007

This page is for the Python implementation of Certified HTTP.

Getting Started

  • Get all the dependencies for Eventlet and Mulib.
  • Follow this little command-line recipe to get them all in one place:
mkdir chttp
cd chttp
svn co https://svn.secondlife.com/svn/certified_http/trunk/certified_http
svn co https://svn.secondlife.com/svn/eventlet/trunk/eventlet
svn co https://svn.secondlife.com/svn/mulib/trunk/mulib
svn co http://svn.red-bean.com/bob/simplejson/trunk/simplejson/
export PYTHONPATH=`pwd`
  • If you're running Python 2.3, you will need uuid.py from the 2.4 distribution (you can snag a copy here).

We know we should get auto-dependencies figured out, but haven't gotten around to it. We'd be happy to accept contributions that speed that process along. [1]