Mesh/Maya Basic Intro Tutorial

From Second Life Wiki
Jump to: navigation, search

Autodesk Maya is one of the most common software for Creating Mesh for Second Life as well as the leading standard for 3D modeling and animation in film, television, and video games. Due to the extensive capabilities it has for such a wide range of applications, navigating the wealth of features packed into this program and finding what is needed to specifically design for Second Life is rather difficult. The following is a collection of lessons to focus specifically on what is needed to use Maya to make Mesh for Second Life.


Video Tutorials


Getting Started With Maya - Layout

Main Menu Bar

There are several levels of depth to the Main Menu Bar. All the menu sets after “Window” can be changed. Select the menus to appear in the Main Menu Bar from the drop-down tab in the upper left corner.

‘Polygons’ will be used most frequently for modeling mesh for Second Life. ‘Animation’ has a few helpful tools plus options for Rigging Clothing and Avatars. The ‘Rendering’ set has options for baking textures and shadows for your model.


Status Line

The Status Line displays a variety of options right below the Main Menu Bar, the most important being the Main Menu Bar selection. Most other actions here do not need to be used often for Second Life besides the snap tools.


Shelves

Each shelf contains different groups of shortcuts for tools found in the Main Menu Bar. You can also create your own Custom Shelf by selecting the small triangle on the far left of the shelves and selecting “New Shelf.” Find the tools you would like to add in the Main Menu Bar and add them by pressing shift + ctrl + Left Mouse Button. As you learn which tools you use most often, adding them to a shelf can save a lot of time in your workflow and make the other shelves almost obsolete to your workflow.


Tool Box

The Tool Box has a few of the basic tools such as the Move, Rotate, and Scale. You cycle through these much faster using the shortcuts on your keyboard using W (Move), E (Rotate), and R (Scale).


Main Window

Your main workspace is viewed by default from a Main Perspective Camera. You can move the camera around several ways, by clicking on the cube in the upper right corner of the window or dragging it around, by holding down alt + Left Mouse Button and panning around, or by selecting one of the camera tools from View > Camera Tools. There are also side, front, and top-view cameras that can be view individually or in a Four View, accessible from the Tool Box.


Channel Box, Attribute Editor, and Tool Settings

The are three small buttons in the top right, and each is very important and will be used constantly throughout the modeling process. Each can be dragged from its dock and either placed on the opposite side of the main window, or can remain overlapping on one side.

  • The far right is for your Channel Box. This displays the basics stats for your selected model, light, material, camera, etc, including it’s position, scale, angle, and the history of modifications to it. Here you can make specific adjustments to these stats. As you make changes to your selection, the history will add up. You can access each until you ‘delete history.’
  • On the far left is the Attribute Editor. This is like an extension of the channel box, giving a lot more depth to the amount of options available to your selection. A new tab will appear for each tool used or material added, allowing more options and settings to be adjusted.
  • In the middle is the Tool Settings. When a tool is selected, it’s options will be displayed in the Tool Settings, allowing you to manipulate how the tool with function.


Hypershade Editor

This can be access from your Tool Box on the left as well as Window > Rendering Editors > Hypershape. This will be used for managing all your textures, materials, and lights in a very convenient and useful space. Learning how to use the Hypershade Editor is essential to creating textures and shadows for your model.


Outliner

The outliner can also be accessed from the Tool Box or Window > Outliner. This reveals a hierarchy of every item in your scene, allowing you to quickly navigate between different items as well as hidden ones.


Time Slider

At the bottom you will find a bar that is divided into increments. Each increment represents different frames that can be played back to animate a model. This is mainly useful for using with Second Life to model fabric using the nCloth system to drape things like blankets or clothing.


Command Line

Here you can use Mel or Python scripts which can be imported. One example was the sculpty exporter plugin for Maya made for making sculpties for Second Life.


Help Line

At the very bottom of Maya, you will find a bar that reveals various help information for where your mouse is hovering over.



Getting Started With Maya - Creating a Model

1. Start a New Project

Select File > Project Window, and then click on the ‘New’ button to type in the name of a new project such as ‘Basic Tutorial.’

Once you have done this, you can save your scene within this project by selecting File > Save Scene and then name your scene. You can save multiple scenes within a project folder. This is important when beginning any new project as it will arrange all of your files including textures baked into a hierarchy that will make it easy to locate your files.

2. Poly Count HUD

Select Display > Heads Up Display > Poly Count

This will activate a small gird in the upper left corner of your Main Window with three columns for 5 different elements of your models. You will notice the first is a total of what is in your current view, and the select is what you have selected. This will be an essential reference for keeping track of the efficiency of your models to make sure prim count is not too high, as well as an indicator of problems such as overlapping geometry like when two faces are occupying the exact same space.


3. Create a Polygon Cube

Select Create > Polygon Primitives > Cube. You will notice there is a small box to the right of this option in the menu like most tools. This is an Options Box, and selecting it will bring up a menu with customisation options. Once the cube is created and selected, these options can also be accessed in the attribute editor on the third tab or node called polycube1. Here you can make initial adjustments to the size and divisions of the cube. Try increasing the Width, Height, and Depth, as well as the Subdivisions Width, Height, and Depth, and watch the poly count rise in your HUD on the upper left.

KBtip2.png Tip: Once you begin to edit your model, adjusting the scale, or location of individual vertices, for example, making changes in this node will render the cube deformed, so try to keep this in mind before you begin your model. You can always add divisions later as well.

You will also notice there are a few other shapes you can create from the Create Polygon menu, such as Sphere, Torus, and Cylinder. Depending on what you are modeling, you can often save time by starting with one of these other shapes, but the great part about working with polygons is that no matter what shape you start with, even a single flat plane, you can modify it into anything you can imagine.


4. Vertices, Edges, and Faces

Every polygon object is made up of a collection of points, each known as a ‘Vertex,’ straight lines known as ‘Edges,’ and flat “Faces.’ Each of these elements can be selected and manipulated individually, as a combination, or all together.

Once you have rotated your model, switch to your Move Tool by pressing W again and go to your Tool Settings. Check the option Object Mode and you will see you can now use the arrows to move your cube along the angle you rotated on rather than by the X,Y, and Z directions.

Hold down your Right Mouse Button on your cube to bring up a ring of options. Here you scroll around the wheel to select which element you would like to choose, or select Object Mode to select an entire model. Try selecting Vertex and either clicking on one of the points or drag selecting over it, then press W to select your Move Tool and try moving the point around. Then, return to Object Mode and press E to switch to Rotate Tool, and try maneuvering one of the rings to rotate your model.

Next, try selecting a face, and then double click the face next to it, and you should then have a Loop of faces selected. You can do this with edges as well, and even select an edge or face a few spaces down the loop to select the faces or edges in between.


4. Add Divisions

To make modifications to your model, you will need to add divisions to this either by ‘cutting’ existing faces or adding on new ones. There are a variety of tools to do this, each using a different method with unique advantages for a different types of situations. The more tools you can learn to do this, the more options you will have to speed up your workflow.

  • Insert Edge Loop Tool

With your cube selected, Select Edit Mesh > Insert Edge Loop Tool and then you can use the tool to place edges by clicking on existing edges on your model. You will notice it creates an edge perpendicular to the one you place it on.

Try selecting one of your new edges by right clicking and going into Edge Select Mode, then double click on any edge to select the entire loop. Then switch to your Scale Tool and try expanding and contracting the edge to adjust the shape of your model.

  • Extrude Tool

Another very common tool is the Extrude Tool. This tool is useful for adding geometry to your model by creating an extension from an existing face, edge, or even vertex to create a new face that can be dragged out.

Try selecting at least one face on your model and then select Mesh > Extrude. This will bring up the extrude tool which you can use to Move, Scale, or Rotate your selection. Move the arrow out to pull out a new set of faces from your model.


Resources

  • Create Mesh offers a variety of comprehensive, step-by-step instructional videos online, everything from basics, to modeling clothing and rigging to your avatar, rendering textures and shadows, and creating a physics model, as well as personal help from instructors.