Object Selection Test

From Second Life Wiki
Jump to: navigation, search

Object Selection Test

Right click Selecting

  1. Create a box on the ground.
  2. Right click the object so the pie menu appears, then click the Edit menu. Verify the box remains selected.
  3. Right click the object so the pie menu appears, hit the Delete key. Verify the box was deleted.
  4. Right click the object so the pie menu appears, select More>More>Inspect. Verify the object stays highlighted, with a purple border, and the inspect dialog shows information about that object.
  5. Keeping the inspect dialog open, right click on other objects and verify that their properties show up in the inspect dialog.

Worn items remain selected as you walk to them

  1. Create a box on the ground about 10m from your Avatar
  2. Close the Build window.
  3. Right click the box > More > Attach > Left Hand. Verify your avatar walks over to the box and the box attaches to your hand.

Worn items remain selected After you attach them if you're in edit mode

  1. Create a box on the ground about 10m from your Avatar
  2. Remain in Edit mode.
  3. Right click the box > More > Attach > Left Hand. Verify your avatar walks over to the box and the box attaches to your hand.
  4. The box will remain selected.

Click Select and Deselect of prims

  1. Create 3 boxes in a row.
  2. Enter edit mode, Ctrl-3.
  3. Click one box to select it.
  4. Shift-click each of the boxes to select them.
  5. Shift-click each of the boxes to deselect them.
  6. Ctrl-click each of the boxes to select them.
  7. Ctrl-click each of the boxes to deselect them (you may need to zoom way in so the boxes are larger than the rotate circles UI).
  8. Delete the 3 boxes.

Drag Select and Deselect of prims

  1. Create 3 boxes in a row (or use previous ones)
  2. Enter edit mode, Ctrl-3.
  3. Click on the ground and drag the mouse to select the boxes with a selection rectangle, one at a time.
  4. Verify that the objects can be selected this way, individually, and as a group.
  5. With all 3 boxes selected, hold down Ctrl and drag a rectangle around one of them.
  6. The object should be highlighted with a red border, and deselected when you release the mouse button. The rest of your selection should remain intact.

Drag select ignores foliage

  1. Create a tree, some grass, and a box. (This may only work on land you own)
  2. Drag select around all of them
  3. Verify that only the box was selected.

(Reverse) Selection order is maintained when linking objects

<lsl> // Link number script default {

   changed(integer change)
   {
       if (change & CHANGED_LINK)
       {
           llSetText("Link #" + (string)llGetLinkNumber(), <1.0, 0.5, 0.0>, 1.0);
       }
   }

} </lsl>

  1. Create a box on the ground and add the above script to the box. (Click the Content tab, click New Script, open the script, replace the script text with the following script text, click Save)
  2. Duplicated the box 2 times so you have 3 boxes.
  3. Enter edit mode, Ctrl-3.
  4. Shift-click each of the boxes (from left to right) to select them.
  5. Link the boxes by hitting Ctrl-L.
  6. Verify the first box you selected is Link #3, and the last box you selected is Link #1.
  7. Unlink the object by hitting Ctrl-⇧ Shift-L.
  8. Link the boxes again by hitting Ctrl-L.
  9. Verify the link order is the same as before.
  10. Unlink the object again. (Ctrl-⇧ Shift-L)
  11. Shift-click the middle prim to deselect it, then shift-click it to select it again.
  12. Link the boxes again by hitting Ctrl-L.
  13. Verify the link numbers from left to right are #3, #1, #2.
  14. Unlink and deselect the boxes. Leave the boxes for the next section.

(Reverse) Drag-Selection order is maintained when linking objects

  1. Use the 3 boxes from the last section.
  2. Enter edit mode, Ctrl-3.
  3. Draw a selection box around the entirety of the 3 boxes by dragging the cursor on the ground from upper-left to lower-right.
  4. Link the boxes by hitting Ctrl-L.
  5. Verify the first box you selected is Link #3, and the last box you selected is Link #1.
  6. Unlink and deselect the boxes.

Limiting Drag Select scope

Select Only My Objects

  1. (Which actually means "Select Objects that are movable and that I have permissions to move")
  2. Enable Tools menu > "Select Only My Objects"
  3. Disable Tools menu > "Select Only Movable Objects" (default)
  4. (Turn on Advanced > Debug Permissions and look at the F:M permission of the object?)
  5. Create 3 boxes
  6. Deed the first box to a group you own.
  7. Lock the second box (Edit window > Object tab > Locked)
  8. Drag select the 3 boxes.
  9. Verify all 3 boxes are selected.
  10. Disable Tools menu > "Select Only My Objects" (default)

Select Only Movable Objects

  1. Disable Tools menu > "Select Only My Objects" (default)
  2. Enable Tools menu > "Select Only Movable Objects"
  3. Create 2 boxes, and Lock one box.
  4. Drag select both boxex. Verify only the unlocked box is selected.
  5. Disable Tools menu > "Select Only Movable Objects"(default)

Select By Surrounding

  1. Enable Tools menu > "Select By Surrounding" (default)
  2. Draw a selection box around half of a box. Verify the box was not selected.
  3. Disable Tools menu > "Select By Surrounding"
  4. Draw a selection box around one corner of a box. Verify the box was selected.
  5. Enable Tools menu > "Select By Surrounding" (default)

Show Hidden Selection

  1. Create a box, then create a larger box above it.
  2. Position your camera so the smaller box is hidden by the larger box.
  3. Drag select both objects.
  4. Disable Tools menu > "Show Hidden Selection"
  5. Observe that you can no longer see the selection of the smaller box.
  6. Enable Tools menu > "Show Hidden Selection" (default)

Texture Selection

  1. Select textures allows you to click individual sides of objects and texture them.
  2. Shift click sides to add or subtract them from the selection.
  3. If you already have an object selected when you change to "select texture", all sides of the object(s) will be automatically selected.

Switching from Texture Select to Position mode will select the objects.

  1. Create 3 cubes. Link 2 of the cubes together.
  2. In the Edit window, select "Select Texture"
  3. Click on one face of the linked child object, and shift-click on one face of the unlinked object.
  4. In the Edit window, select "Position"
  5. All 3 prims should now be selected.
  6. Delete the objects

Edit linked parts

  1. Create 5 boxes. Link 2 together. Link 2 others together.
  2. In the Edit window, enable "Edit linked parts"
  3. Shift-click prims within the linked sets to add and subtract them from the selection.

Selection conversions

  1. Create 3 boxes. Link them together.
  2. Select the linked boxes. With the boxes selected, check "Edit Linked Parts."
  3. Verify that all 3 boxes are individually selected.
  4. With "Edit Linked Parts", select just one of the boxes. Uncheck "Edit Linked Parts."
  5. Verify that the linked set of 3 boxes is selected.
  6. With the linked boxes selected, click on "Select Texture."
  7. Verify that all textures on the 3 boxes are selected.
  8. Select one texture on any of the boxes. Click on "Position."
  9. Verify that the linked set of boxes is selected.
  10. Select textures from multiple unlinked prims, then click "Position."
  11. Verify that all prims you clicked on are now selected.

Select your attachments

  1. Attach a box to one hand and a linked object to the other hand
  2. Verify you can select either attachments by right-clicking it.
  3. Enter Edit mode (Ctrl-3), and select both attachments. Verify you can move, rotate, and scale both attachments at the same time
  4. In the Edit window, enable "Edit linked parts"
  5. Verify you can select any prim on your attachments by right-clicking it.
  6. Select the single box attachment and one prim of the linked attachment. Verify you can move, rotate, and scale both prims at the same time

Select other's attachments

  1. Right click someone else's attachments. Verify the pie menu when right-clicking someone else's attachment is the same as when right-clicking the avatar.
  2. Verify you do not see
  3. Enter Edit mode (Ctrl-3), and select another avatar's attachment. Verify you do not see any move widgets and you are not able to modify their attachment in any way.

Select other's vehicles

  1. Enter edit mode (Ctrl-3) and verify you can select other's vehicles and their vehicle stops. Unfortunate.

Block Grab LSL flag

<lsl> default {

   state_entry()
   {
       llSetStatus(STATUS_BLOCK_GRAB, TRUE);

// Controls whether the object can be grabbed. A grab is the default action // when in third person, and is available as the 'hand' tool in build mode. // This is useful for physical objects that you don't want other people to // be able to trivially disturb. The default if FALSE.

   }

} </lsl>

(This doesn't work. I can jiggle other people's physical objects that have this script)

Deselection

Verify the following methods will unselect objects

  1. Hit escape
  2. Ctrl-E
  3. Click another object
  4. Click the ground
  5. Clicking the sky
  6. Object moves too far away

Verify the following methods will not unselect objects

  1. Walking or flying near the object

Limit Select Distance

  1. Enable Advanced menu > Limit Select Distance (default)
  2. Verify you can drag objects that are within 65m of you.

Disable Limit Select Distance

  1. Disable Advanced menu > Limit Select Distance
  2. Verify you can drag objects that you can see, even if they are > 65m from you.
  3. Enable Advanced menu > Limit Select Distance (default)

Retain edit-selection when object changes regions

  1. Create a box, and remain in edit mode.
  2. Drag the box onto an adjacent region, and verify it remains selected.
  3. Deselect, then reselect the box.
  4. Drag the box back into the region you are in, and verify it remains selected.

Retain drag-selection when object changes regions

  1. Create a box and set it physical.
  2. Enter Move mode (Ctrl-2).
  3. Drag the box up into the air (Ctrl drag upwards) then drag the box onto an adjacent region, and verify the box remains selected and suspended in the air.
  4. Release the mouse button and verify the box falls to the ground
  5. Drag the box back into the region you are in, and verify it remains selected.
  6. Delete the box.

Selection after unlinking

Unlinking whole set

  1. Link 3 boxes together.
  2. Select the object and unlink it.
  3. Verify all 3 prims are selected.

Unlinking piece(s) from linked set

  1. Link 4 boxes together.
  2. In the Edit window, enable "Edit linked parts"
  3. Select two child prims and unlink them.
  4. Verify the two prims are unlinked and remain selected.

Max number of selected prims

There is currently no hard-coded limit to the number of selected prims.

Focus on selection

  1. Close your chat bar.
  2. Create several boxes then drag-select them.
  3. Press H. (or choose Tools menu > Focus on Selection)
  4. Verify your camera rotates to center on the group of objects.

Zoom to Selection

  1. Close your chat bar.
  2. Create several boxes then drag-select them.
  3. Press Shift-H. (or choose Tools menu > Zoom to Selection)
  4. Verify your camera rotates and zooms to center on the group of objects. (The objects should fill the center 1/3 of the screen.)