Panorama

From Second Life Wiki
Jump to: navigation, search

Welcome to the art of epic.

This guide shows you how to make a lovely, wide-angle view of a Second Life scene such as:

Here-island-panorama.jpg

Play with this and more examples in 3D.

Preparation

Make sure to set your graphics preferences before getting started. You should be on a high-end computer that fully supports all of Second Life's visual effects with ease. Torley prefers running SL as a maximized window to capture as much of the screen at once while being able to switch to other applications, such as the panorama editor.

  1. Go to Edit menu > Preferences and click Graphics tab.
  2. On the Quality and Performance slider, click Ultra.
    • Optionally, check Custom and increase Draw Distance to 512 m. This may severely drop framerate but provides a much longer range of view.
    • Also, disable Avatar Impostors — they speed up performance but look cruddy in a high-res scene.
  3. Click Input & Camera tab, also in the Preferences.
  4. Uncheck Show Avatar in Mouselook.
  5. Click OK.
  6. Teleport to a location you want to make a panorama of.
  7. If you can't get a good enough view of your surroundings, fly 25-50 m above the terrain mesh — or even more if the environment has extremely varied heights.
    • You should feel like you're in a "sweet spot" where everything around you looks wonderful and interesting: rolling hills on one side, a majestic waterfall in another direction, and assorted buildings to the north. See varied examples.
  8. Go to World > Environment Settings and click Environment Editor to change your WindLight/time of day setting.
    • For instance, if you're at a beautiful beach, opt for a rosy sunset.
    • Clear skies can look pretty, but they're harder to match since a solid (or subtle graduation) of color doesn't look particularly unique. Try experimenting with different degrees of clouds and sky gradients.
  9. Wait for the scene to fully rez in. You don't want gray or blurry textures.

Photography

This should take no more than 3 minutes on a capable computer.

  1. Use File menu > Take Snapshot.
  2. Select Save to your hard drive.
  3. Under Format, select PNG or BMP. The former saves space but will take more time on slower computers.
  4. Click Save button, create a new folder to save your first round of panoramic images to, and save it. This is your test shot.
  5. In your operating system's file navigation system, open that image to make sure it saved correctly. Then, you can delete the test shot.
    • Torley has dual monitors and likes to keep one window open on his desktop showing thumbnails of images as he goes along.
  6. In Second Life, go into mouselook from View menu > Mouselook, or simply press "M" key when the chat bar is closed.
    • There's likely a way to script a more systematic means, but I haven't seen one yet.
  7. Since you can't see menus in mouselook, you'll need to use the File > Snapshot to Disk shortcut, Ctrl-` (Strg-ö on german keyboards). Start moving your mouse around and take pictures of every angle around you. Overlap is fine. Make sure you don't leave any gaps in the sky. Don't move your avatar aside from doing the necessary rotations.
    • A finished panorama can typically consist of 50-200 images; less if you have a high screen resolution such as 1920x1200, more if you do a lot of overlap.
    • Don't log out of SL yet. If your panorama editor can do a quick preview, it'll show missing areas where it was unable to join or identify images. If you haven't moved your avatar, you can take some extra shots, run another preview, and see if those holes get covered up.

Rendering

You'll need a 3rd-party panorama editor to "stitch" the many images into a single one, such as:

This article or section is missing vital information. You can help the SL Wiki by editing it.

3rd-party panorama editor suggestions... and stuff


Advanced

It's greatly beneficial to reduce all moving elements in the scene. Smart panorama software can remove them without ghosting, but in case you need additional help:

Freezing the sky

  1. Go to World > Environment Settings > Environment Editor.
  2. Click Advanced Sky.
  3. Click Clouds tab.
  4. Click the 'Lock buttons next to both Cloud Scroll X and Cloud Scroll Y.
  5. Also uncheck Draw Classic Clouds — they keep moving no matter what.

Freezing the water

This isn't a total freeze, but it's close enough.

  1. Go to World > Environment Settings > Environment Editor.
  2. Click Advanced Water.
  3. Click Image tab.
  4. Set all Big Wave Direction and Little Wave Direction X-Y sliders to 0.00.

Freezing flexiprims

  1. Enable Advanced menu.
  2. Disable Advanced > Rendering > Features > Flexible Objects. Flexis will freeze.

Other things can be frozen in the Advanced menu, such as toggling Advanced menu > Rendering > Animate Textures.

Uniform surfaces

Uniform surfaces can be very difficult to stitch as they have no points to join, or these points are indistinguishable because of uniform texture. Automatic stitching software usually fails on cloudless sky or floor made of wooden planks.

To workaround this problem, use two long sticks crossing each other. The sticks can be almost invisible (stitching software perfectly recognizes them anyway). Put the sticks on the floor and/or ceiling and process with a screenshots.

The example of the panorama made with stick helpers is available here: panorama with sticks at the floor and ceiling.

The sticks can be easily removed in Photoshop after you make the final panorama image. However, they are almost invisible for end-user.

See also

Awesome panoramas

The art itself!