Talk:XyText 1.5

From Second Life Wiki
Jump to: navigation, search

What Is the license for this code? Can I assume it is the CC-by-sa like the rest of the wiki?

XyText as it was originally released did not have the "sa" restriction; it is typically distributed & used in a closed source form. That said the community would appreciate the donation of any improvements made to it. -- Strife Onizuka 03:02, 24 September 2007 (PDT)

Letters

Wouldn't This Be More Texture Efficient In World If Its Letter Index Took Letter Frequency Into Account? So The Most Likely Combinations Are On Fewer Textures?Adi 17:49, 28 March 2011 (PDT)

Hi, there could be some saving with a different character sort, but this doubled character technique becomes less attractive once mesh can move to the main grid. This forum post shows how the new equivalency system could make even the "5 character" type of XyText use a much smaller prim count. --Cerise Sorbet 20:02, 28 March 2011 (PDT)

That Will Defiantly Help Eventually, But Even Then Character Sort May Still Make A Difference. Ill Have To Play Around With Both And See. Adi 10:41, 29 March 2011 (PDT)

Oh, what I mean, is that once the prim count can go down, it is easier to get away with the older 5 character system, and that only needs a single texture, maybe 2 if you want lots of characters. Then sorting is not a problem, and the fewer textures can load much more quickly and use less video memory. --Cerise Sorbet 11:11, 29 March 2011 (PDT)
Oh i Get What You Mean Now, My Head Was Just Stuck Thinking In Character Pairs Adi 12:47, 30 March 2011 (PDT)

Some characters appeared blurry

I created a noticeboard using these textures & scripts (slightly modified) & noticed some character pairs were blurry (eg: "ti" & "po"). I looked through the textures in the CHARACTER_GRID list and found the 43rd (e3ce8def-312c-735b-0e48-018b6799c883) to be the culprit. This one seems to have been a low rez jpg or something.

Mars Tamale

That texture looks all right from here compared to the others, but unfortunately yes, it's very common for a viewer to load some XyText textures only partially. It can take a relog, and occasionally a cache empty, to fix it. This is really a more general old problem with texture downloads in Second Life, some viewer releases are better than others at downloading everything fully. Since these scripts rely on groups of textures, the problem is more glaring.
To alleviate the problem, and get a visual performance boost at the same time, use one of the xytext variants with fewer textures, if your character set allows it. --ObviousAltIsObvious Resident 08:09, 29 August 2014 (PDT)
it s not the most current problem :
Textures are displayed with the default mode . And the default mode is "Alpha Blend" .
  • With alpha blend ,
    • it will look ALWAYS blurred
    • it will be really more consuming to Lag Graphic : the result compute all the different levels of half transparency , must sort the objects in the foreground and back ground to know which object overlaps , and can t use VBO while the moment of display
  • With alpha mask :
    • pixels to displayed are either full transparent either full opaques : there are are no half-transparency . It s a fast display
    • the textures could look pixelisated at low level of cut mask ; it depends how the textures has been created on gimp , photoshop etc .
    • the textures could look fine ( low lag , no pixelisated , smooth ) if an other level of cut mask is chosen
The main problem is "what level of cut off to choose"
The textures on gimp/photoshop have been created with blur efect or anti aliased affect : the best solution should to recreate them, reupload them to take profit at the maximum of alpha mask . Nevertheless , an average cut off of alpha mask in second life could be enough
Alpha Mask and Alpha Blend on Characters textures.png
This script , and all the scripts who deal the characters to display from a texture , must use alpha mask for better performances , and to look less blurred . At the time of the creation of script , alpha masking didn t exist

Miranda Umino 16:09, 3 September 2014 (PDT)

The masking option is nice to have, but that was not the problem here, as of course these scripts and textures appeared at a time when alpha blending was the only method available. Even the automatic mask (formerly "fast alpha" was a later development.
In this case, the problem is much more simple, textures do not always completely download, with the result that some characters may be rendered at a less than ideal mipmap level. That is why a cache clear worked, it forced the affected textures to be downloaded again, this time correctly.
The masking option also introduces a problem. You lose antialiasing on these texture edges, though the situation is somewhat improved on clients that can support advanced lighting and have that option enabled. --ObviousAltIsObvious Resident 16:31, 3 September 2014 (PDT)

Thanks - You hit the nail on the head. I cleared cache & all was well -- Mars