Talk:Compiling the viewer (MSVS2003)

From Second Life Wiki
Jump to navigation Jump to search

Is this ActivePerl 5.8.x or 5.6.x? I'm guessing 5.8, but I would like someone to confirm it. Kunnis Basiat

I used 5.8, I think both will work. Ben 14:45, 9 January 2007 (PST)

I have winxp pro 64 bit, and there isn't a 2003 DirectX SDK for me. I used the April 2006 and i didn't have any problems. Should we add this as a suggestion? Where should we put tips and tricks we figure out? Kunnis Basiat

You can either use this page, or create a page off of it for tips and tricks. Yay for wikis Ben 14:45, 9 January 2007 (PST)

Platform SDK vs the DirectX SDK

Right at the top:

Make sure that the includes and libraries paths have the DirectX SDK paths first, then the Platform SDK paths, and then the Visual C++ paths.

I just downloaded fresh copies of the platform and dx sdks, and this doesn't work. You need to have the platform sdk includes come first, or you get a conflict in the two versions of basetsd.h.

is the version of the platform sdk linden is using not the RC2 version that downloads now from the website?

Not sure if this a question or a statement, sign your notes, so I don't need to dig into the history Ben 14:45, 9 January 2007 (PST)

The Platform SDK should be first in the list, as noted above. Change made. Peekay Semyorka 16:25, 31 January 2007 (PST)

Compiling APR with VS2003

The compilation instructions from apr indicate that we should open and convert /apr-util/aprutil.dsw (the workspace which includes all of the projects) and not aprutil.dsp (just one project).

I'm a little slow and got hung up last night trying to figure out what was wrong. This worked for me, so I hope this helps somebody. I'd change it myself on the main page, but I'm a chicken! :) Tekilah Elytis 09:36, 9 January 2007 (PST)

Unexpected response while applying patch to XMLRPC-epi

The first path worked without a glitch, but now I am stuck.

The build page mentions that patch 1 & 3 should be applied, so I have skipped the patch "rename_queue.patch", but when applying the "excise_expat.path" my results vary from the prescribed.

(Stripping trailing CRs from patch.)

can't find file to patch at input line 4

Perhaps you used the wrong -p or --strip option?

The text leading up to this was:

|diff -ur xmlrpc-epi-0.51-old/Makefile xmlrpc-epi-0.51-new/Makefile

|--- xmlrpc-epi-0.51-old/Makefile 2006-04-27 14:55:33.000000000 -0700

|+++ xmlrpc-epi-0.51-new/Makefile 2006-04-27 15:16:19.886773976 -0700

File to patch:

where the "File to patch:" is a prompt, requesting a file name? any suggestions for moving forward? Duffy Langdon 15:31, 9 January 2007 (PST)

This might work...try -p0 instead of -p1 for excise_expat.patch?
I actually couldn't get the patches to work, but it was relatively short and simple to follow the patch file and change them manually. Tekilah Elytis 17:05, 9 January 2007 (PST) (edit: Fixed my patch problem anyway.)

How to build boost on a win 64 machine

I am using a windows XP 64 bit version, and had some difficuties building the boost libraries, using the description on this page. The problem turned out to be related to a bug in CMD.EXE and the fact that visual studio is installed in C:\Program Files (x86)\bla.bla.bla. the Build.bat relies heavily on IF statements, and the parenthesis used when combining several commands conflicts with the parethesis in (x86).

I am not terribly familiar with boost, but it turn out that the first step are required to build a build tool called bjam.exe. This build tool can be downloaded from the Boost sourforge site, which probably will be the easiest workaround for this bug in Windows XP. Duffy Langdon 15:48, 9 January 2007 (PST)

Error "Building ytab.cpp"

I get the following error:

lscript_compile_fb error PRJ0019: A tool returned an error code from "Building ytab.cpp"

It may possibly occur because I installed Cygwin in an "unexpected" place. I have it in "C:\User\Cygwin" rather than directly under the root of C:\. I have adjusted the only hardcoded Cygwin directory location reference I could find (which was in llinventorymodel.cpp). [User:Synthalor Mandelbrot|]] 14:56, 16 January 2007 (PST)

[1/19/2007] I also added the Cygwin bin directory to my Windows XP path, but that didn't fix the problem.

More probably, it may happen because Cygwin's yacc is not a true executable (Windows style), but rather a shell script around bison.exe. When trying to execute it from Visual Studio.NET 2003, the system may not understand that it needs to execute a Cygwin shell script.

Here is what the yacc file contains:

 #! /bin/sh
 exec /usr/bin/bison -y "$@"

Is there any known workaround for this? Synthalor Mandelbrot 12:04, 19 January 2007 (PST)

I just encountered this, but I think I've figured it out. Visual Studio apparently maintains its own list of paths, and ignores the Windows XP PATH environment variable. Go to Tools > Options > Projects > VC++ Directories . With "Executable files" in the dropdown, add your cygwin and python directories. I've updated the instructions at Microsoft_Visual_Studio#Setup_the_project_globals accordingly. Celierra Darling 21:18, 4 February 2008 (PST)