Talk:Get source and compile

From Second Life Wiki
Jump to navigation Jump to search

The Linux section of this page was a mess. It looked like it might have been created by a browser bug or something, since it seemed to grow on every edit, with duplicated text from the windows section. I nuked it when I split the page out. -- Rob Linden 22:47, 12 December 2006 (PST)

I'm just starting out with open source projects and I've managed to re-compile a project or two--but only in knoppix linux. I don't have the suite that is seems needed for the windows compile but I have cygwin and MinGW installed and have downloaded all the necessary includes for the sl source--but following the linux instructions in windows doesn't seem a plausible experiment to try. Anyone got some compile instructions for people who want to recompile in windows with open source tools? Dom DaSilva 8:14P 01.09.07.

After compiling a debug build of the viewer I noticed that there is a server selection drop down of some sort to the right of the preferences button. Which of these should I be selecting to login? The only one that does anything interesting is "Aditi" and it just tells me that I need to download a newer version of the client and quits.

If I need to be connecting to the beta grid that's fine, but it would be helpful to know what each of these servers are. I suspect that "DMZ" and "local" are internal to Linden Labs, and that "Aditi" is likely the live grid, but what about the others?


Kage Pixel 17:33, 11 January 2007 (PST)

This is probably too late, but you can just change your channel to get to the main grid: see Channel and Version Requirements. Celierra Darling 14:58, 8 March 2008 (PST)

VC++ 2008 Express

I have posted a synopsis of the steps I took to successfully compile the 1-21-r99587 source using VS C++ 2008 EXPRESS at the link below:

How I Compiled SL Source w/ VC++ 2008 Express Edition

Hope it helps someone.

--Jodiah Jensen 15:14, 29 October 2008 (UTC)

Trying to build Snowglobe 2: it is driving me nuts


I've been trying to get Snowglobe 2 to build for the past several days, and it still refuses to work. Have successfully built older versions of Snowglobe before. Some background: I'm using VC++2005 Express on XP.

(1) First few times I tried, VC++ failed to build 2 projects. It generated an executable which worked - sort of. HTML display wouldn't work at all because the MIME type was unrecognized for some reason.

(2) After that, the next time I did a test build and ran it, Snowglobe popped up an EULA window. No HTML = no EULA = no way to continue.

(3) I thought it could be because I had installed VC++ to the default directory, so I uninstalled it and installed it to a directory with no spaces in the path. That was when everything started to go even more pear-shaped.

(4) Attempted to build, and half the unit tests failed. The executable itself refused to run - "incorrect application configuration" or some such.

(5) Was wondering if it was because I hadn't installed NSIS Unicode. Installed it. Nothing changed.

(6) Wiped the whole source directory, reconstructed it from scratch, ran cmake again, attempted to build. Same problem.


Edit: Just realised that the net installer for VC++ does not automatically update with SP1. Updated it with SP1. Unit tests are still failing. Just noticed the error code: -1072365566.

--Aznavour Wolfe 03:51, 9 April 2010 (UTC)