Mesh/Exporting a mesh from SketchUp

From Second Life Wiki
< Mesh
Revision as of 01:44, 16 May 2015 by Curiber Resident (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Google SketchUp 7.0 is a free 3D modeling program available for Windows XP/Vista/7 and Mac OS X 10.4 and later. It stores model files in its own .skp format, but it can export models to the Collada 1.4 .dae format that Second Life uses to import models. What follows is a basic workflow for using SketchUp to import a model to Second Life.

Create Your Object in SketchUp

Step 1: Download SketchUp version 7.0.10247 (Windows-only) from the FileHippo.com website and install it on your computer. Note this is not the current version (8); the newer version does not import to Second Life properly. So ignore any prompts from the software to upgrade to the latest version. You can get the SketchUp Manual in PDF format for version 7. (11-2-12: My experience: Using Sketchup 8 I was able to download a simple mesh model with no problems. I am using the most recent Secondlife viewer, with Mac OSX. - Rufferta) (04-2-13: My experience: Using Sketchup 8 and Phoenix Firestorm c4.0.1.27000 and Windows Vista, I had no problem uploading a simple mesh model either - Anna)

Step 2: Start SketchUp 7, and in the Welcome to SketchUp window, click the Choose Template button. Select Simple Template - Meters and then click Start Using SketchUp

Step 3: You will see a human figure in the perspective view. Before exporting your model, left click this figure and type Delete, otherwise the figure will be imported to Second Life along with your model.

Step 4: Select the Line tool (second from the left) on the toolbar, and draw a set of line segments to make a closed shape. It will turn gray when you connect back to the initial point. Now select the Push/Pull tool (tenth from the left), left click on the shape, and move the mouse forward to raise the shape and make a solid object. Hold the middle mouse button or select the Orbit tool (14th icon), then move the mouse to rotate your camera view. Rolling the mouse button will zoom the view. You can draw more lines with the Line tool on existing sides of the object, and push and pull the sides to change the shape. Other tools can be used to further modify the shape. For more details on using SketchUp, consult their manual or widely available tutorials online.

Step 5: Select the Paint Bucket tool (9th from the left). Under the Select tab, choose a material type from the drop-down list, then click one of the thumbnails to choose a texture. Now left click on each face of your object to assign the texture. Put a texture on every side of the object, up to a maximum of 8 different textures, so it will have a texture mapping once imported to Second Life. Save the SketchUp file using the File > Save As... menu item.

Step 6: Use File > Export > 3D Model menu item, and choose COLLADA File (*.dae) as the Export type. Name the file and then click Export.

Upload to Second Life

Conditions Must be registered & complete LL's IP Tutorial

Step 1: If you do not have it installed yet, get the most current Second Life Viewer Beta from the Release Notes for Beta Version page linked at the bottom of this page. Currently this is version 3.6.1. Select Mode: Advanced on the log-in screen and restart. Then select Start at: Aditi (i.e. the beta grid), and log in. Find your way to one of the Mesh Sandbox map regions.

Step 2: Choose Build > Upload > Model from the main menu. From the file browser, choose the .dae format file you unpacked previously. In the Upload Model window choose the Upload button. After a few seconds your model will appear in your inventory. Drag it onto the ground in the perspective view. You can now apply textures to the white object. There should be as many "surfaces" to apply textures to as you had different textures in the SketchUp version.

Video Tutorial

Second Life Mesh from SketchUp Updated

Best Practices

Forum thread on SketchUp best practices Another thread on exporting from SketchUp to Second Life

Bones and Rigging

Gotchas and Workarounds

Optimization Techniques

Second Life Mesh from SketchUp Updated

Tutorial Links