Texture Windows

From Second Life Wiki
Jump to: navigation, search
KBcaution.png Important: This is an unofficial guide for Second Life Viewer 1.23 helpfully compiled by Second Life Residents. Much of it does not apply to the current version of the SL Viewer (Viewer 2).

This page is part of the User's Manual. It covers the texture-related windows in the Second Life viewer. Photos have their own category in inventory, but otherwise behave the same as textures.

Color Picker

This window lets you add a color tint to an object's textures. It applies to all surfaces of an object. It is opened by clicking the Color box in the Tools > Edit > Texture window. The built in color picker can be changed with Advanced Menu > Debug Settings > usedefaultColorPicker item.

There are three color systems: RGB, Hue/Saturation/Luminosity, and the color chart. Three values are required to specify a color because the human eye has three color sensors. Setting with any of the 3 systems will set the values on the other two to corresponding values.

Color Picker Window

Red:, Green:, Blue: - This system uses number values from 0 to 255 for each primary color, where 0 represents dark or black, and 255 represents light or white.

Hue:, Sat:, Lum: -

Color Chart - The color chart graphically reproduces the Hue/Saturation/Luminosity system. Clicking anywhere in the large color box will set that hue (horizontal axis) and saturation (vertical axis). Clicking the grey strip to the right will set the luminosity.

Sources of color values can be found at 500+ Named Colors page. A tool such as Peacock Color Picker can be used to match a color on an existing item.

Current color: - Shows the current color selected with the above systems. You can click-drag to the preset colors palette below to save the color.

Preset Color Palette - 32 colors can be saved in this area, 28 of which are defined by default.

Apply Immediately - If checked, the current color is applied immediately to the object being edited.

Eye Dropper -

Cancel - Closes the window

Select - Applies the current color to the object being edited, and closes the window.


Pick: Texture Window

Pick: Texture

This window lets you select a new texture for an object being edited. It is opened by clicking the Texture box in the Tools > Edit > Texture window. Alternately you can drag a texture directly from inventory to a face of the object.

If the Select Texture button on the upper pane of the Edit tool is active, a target will appear on one face of the object when you click on it, which will then be the side you change. If the button is off, then all sides of the object are changed.

Texture Thumbnail - The upper left part of the window shows a thumbnail view of the texture. Textures which have transparent (alpha) layer will show a checkerboard background.

Dimensions - Gives the size of the full texture in pixels

Defaut - Selects the system default textures, which is yellow plywood.

Blank - Selects a plain white texture.

None - ?

Apply Immediately - When checked, your texture choice is applied immediately to the selected object, which is useful if you want to see the results quickly.

Eyedropper button - When you already have an object selected, clicking this item lets you 'pull' a texture from another object, and then apply it to the first one. You must own the texture for this to work.

Search box - Entering part of a texture name here will filter your inventory list to matching items.

Texture List - Shows any folders in your inventory which contain textures. Clicking any texture will add it to the thumbnail window.

Cancel - Closes the window.

Select - Applies the selected texture and closes the window.


Snapshot Preview Window

Snapshot Preview

This window lets you take a screenshot or photo from the 3D view on your screen. It is created by saving one frame generated by your graphics card. It is opened by the top menu File > Take Snapshot item, or the bottom toolbar Snapshot button. The frame is saved at the time you click the item or button.

Snapshot destination - Lets you set where the snapshot is saved:

Send via email - opens the Email Snapshot to send a .jpg version by email directly from within the viewer program.
Save to your inventory - Will upload the image to your personal Second Life inventory. You will be charged L$ for this. Depending on server load, image size, and internet speed, this may take several seconds.

Images saved on Second Life are forced to the nearest power-of-two dimensions (16, 32, 64, 128, 256, 512, or 1024) in each direction. The maximum size for new images is 1024x1024 pixels.

Save to your hard drive - Will save the image in PNG format on your computer.

Photo thumbnail - A small version of the image is shown. It will have the same aspect ratio as your screen. If custom image size is selected, the discarded portion of the screen view is greyed out.

File size: - Shows the file size for the currently selected save option.

Refresh Snapshot - Updates the image to the latest screen frame.

Save/Save As - When clicked, will save the image.

Cancel - Closes the window without taking a snapshot.

More/Less - Opens more options for your snapshot

Size - Lets you choose from the current screen size, some standard desktop sizes, or custom dimensions.

Format - Lets you choose PNG, JPG, or Bitmap image file types.

Width/Height - Lets you set the pixel size directly. The maximum size is 6016x6016.

Constrain Proportions - Makes the image dimensions keep to the current screen aspect ratio.

Capture: - ?

Show interface in snapshot - By default, snapshots only include the 3D view, and not any windows you may have open. If checked this item will include the windows, menu, and toolbar.

Show HUD objects in snapshot - Head Up Displays (HUD) are objects attached to the plane of the screen, in front of the 3D view. By default they are not included in the snapshot. Checking this box will add them.

Keep open after saving - Will keep this snapshot window open for taking additional photos.

Freeze frame - ?

Auto-refresh - ?


Texture Window

Texture

This window displays textures in your inventory. It is opened from the inventory window by right click the texture Context Menu > Open. You can select a range of textures and open them, which will display all of them in a tabbed preview window.

Objects in Second life have a shape defined by a wireframe mesh, and a texture applied to the surface of that mesh to make it look solid and three dimensional. The mesh is a mathematical description of the corners and edges of the object. You can actually see it if you use the top menu Advanced > Rendering > Wireframe item.

Textures are JPEG2000 format images that are downloaded to your computer, stored in a cache on your hard drive, then applied to the surface of objects to create the 3D view. Since the shape and textures are downloaded separately, any objects that have not had their textures downloaded yet are shown in plain grey. Textures not in your inventory are not directly viewable.

Title Bar - Shows the texture name as listed in your inventory if for a single texture. For multiple textures part of the name is shown on each tab.

Tear Off Button - When multiple textures are opened in preview mode, this button lets you separate or join a texture from the tabbed view to a separate window.

Description - Optional description field

Main Texture Box - The texture window can be stretched to view it more easily. Textures with a transparency (alpha) channel are shown with a checkerboard background on the transparent parts.

Dimensions - Horizontal and vertical size of the texture in pixels. Textures have power-of-2 (32, 64, 128, 256, 512, and 1024) sizes to efficiently fit in graphics memory, and are limited to 1024x1024 for newly created ones. A few legacy textures are larger.


Upload Image Window

Upload Image

This window lets you upload a new texture or photo to the Second Life system. It is opened via the top menu File > Upload > Image item. This opens a file browser on your computer, and once you choose an image it will open this window. Once loaded to the database, it appears in your inventory, and can be used on objects or shared with other users. A fee of L$10 is charged per upload. The image part of a texture cannot be edited once uploaded.

Source images must be in one of the following formats BMP, JPG, PNG or TGA file with at least 24-bit color. TGA files may also be saved as 32- bit files, which allows the use of an alpha channel (a form of transparency). You may not upload files saved in 8-bit, 16-bit or palletized color.

Aspect ratios - The aspect ratio is the ratio of horizontal to vertical size of an image file. Image sizes are rounded to the nearest power of 2 (16, 32, 64, 128, 256, 512, and 1024) pixels in each dimension. The maximum size for new textures is 1024x1024. Larger source images are resized to 1024 pixels. To avoid distortion you may want to make your source image one of the final sizes to start with.

Note: Profiles and search present images in NON-power of two aspect ratios, so if that is your intended use, it is better to start with an image in the final display aspect ratio. It will be distorted when uploaded, but un-distorted when displayed for that purpose.

Title Bar - Shows your source file name

Name: - Allows you to enter the name it will be saved in your inventory under. By default it is the same as the source file name, with a limit of 65 characters

Description: - You may enter a description up to 127 characters in length. Note that descriptions are not searchable in inventory, so use the name if you want to find an item more easily.

Preview Image as: - ?

Preview box - By default shows a preview of the original image.

Use lossless compression - For certain purposes (sculpt textures), your source file should be uploaded without any data loss. Checking this box will do that.

Upload (L$10) - Uploads your source file to the Second Life database and charges your account L$10. This may take several seconds depending on the file size, your internet speed, and how busy the Second Life system is. If the upload fails, you should not be charged.

When the upload completes, the texture will appear in your inventory list, and a Texture window (above) will open to display it, replacing this window.

Cancel - Closes the window without uploading.